Render is inconsistent

I am having a challenge rendering a scene. At first it renders just the background and then it will render the scene with everything as a solid. I have checked and my objects are set to render and my settings seem correct. Anyone know of a process to troubleshoot to make sure render settings are correct? It is so odd that I will press the same render button and get a background render one time and then the entire scene another time with all the objects but as a solid.

Check your “Render Layers” or upload a .blend for troubleshooting.

Hi have you tried to check if the lock layer to scene is clicked on the header?


I have checked my render layers and they are checked for render, I have also checked the locked layers is enabled. I wish I could upload the blend file but the size is too much for the site and would be counter to the problem since I am trying to render the entire scene. I can at least breakdown what is going on. When I try to render via the clapperboard icons in the lower right of the the 3D view window, The render turns up as “no layer in render result” and returns a screen with all of my objects but in solid form.

When I try to render using either the menu item in the top menu bar or the render animation option in the render properties, both return a render with just a portion of the backdrop plane I have in the scene but nothing else. I am including an image You can see that I can get the 3d View window to render but not the scene in animation.

Could you share screenshots of:
Render layers properties
A console(cmd/terminal) after a render

Check also if:
Postprocessing(compositing and sequencer)are enabled
Are there other scenes
Is there any script

Try to:
Open a vanilla blender to render the scene(no add-ons/UI customisation)
Append the whole scene into a new blend

Tell us if you notice something strange in any case


Ps: just to be sure… the render button below the viewPort is meant to render an OpenGL version of the scene so it will render solid or material or wireframe or texture depending from the previsualization mode but it doesn’t handle the rendered. If you want to use the cycles just press F12

Thank you sparazza for all your help. Just to catch you up on your previous suggestions. I checked Postprocessing (compositing and sequencer) and they are enabled. There are no other scenes or script. I am not sure what you are talking about regarding cmd /terminal lines. I am on a Mac but not sure how that plays into the Terminal window if that is what you are talking about.

I opened a base Blender file with no addons, appended the scene, and still got the same results rendering F12(rendering only a part of the plane I am using in the background without the object rendering). Just to be clear as well, the items to render are designated for rendering in the Outliner so that was checked. Here is a screen shot of my entire render properties. I set the sample low to get a faster result while troubleshooting. I am rendering though at 4K. Although I have used these before without a problem.

FOUND IT!! While troubleshooting my settings, I could not find what the problem was since my setting appeared correct. Then it dawned on me that I had an object in front of the camera that I turned off for this shot but did not turn off the final render setting. Thus everytime the viewport showed a correct image, the final render included the object. Sometimes you can’t see the forest for the trees…literally. Thanks for everyone trying to help me solve this problem.