Render keeps filling memory and crashes

Cycles and Eevee both, render fills up system ram and then crashes Blender.

  • Tested with Blender 2.82 stable and 2.83 daylies;
  • Windows 10 64 bit, 32Gb ram, GTX 2060 super;
  • crash happens with both CPU and GPU renders: pure CPU, CUDA, Optix;
  • sampling is set at 128; caustics are disabled, factory denoiser (tested also without); render size is 1280 x 1920 px;
  • scene is >100.000 triangles: 4 rigged characters, 2 of them using the same diffuse (2k), cavity (2k) and height (2K); one using only a procedural noise texture, and one using udims (2K + 1K) for diffuse, cavity and height;
  • 3 of the characters have multiple hair particles systems (hair, eyelashes, eyebrows, beards) with different materials (hair principle node);
  • the rest of the scene has untextured materials;
  • viewport cycles preview is fine;
  • whole scene, freshly loaded in Blender takes up about between 600 Mb and 1.5 Gb; as the program is unresponsive (or lagging) during the render, a check on the system resources show the consumption rise up to the whole system memory, at which point the system hangs.
  • it seems, but don’t take it for sure, to hangs when loading kernels (rather, before any writing appears in the render window.

I’ve tried both factory settings, and optimised ones (larger tiles, lower light bumps) so far with no success.

Any suggestion please?

You are going out of RAM.
Use CPU render settings and small tile sizes.
You have to optimize your scene:
Try some options: “simplify” in render panels
or
split your scene in chunks where you can render it.

If Blender goes out of (system)RAM, it will use your SWAP, try to increase that.

1 Like

Thank you for your reply!
I tried those things without success, until just now I found I left over a subdivision modifier to an object with a ludicrous subdivision level, which was the culprit.
Solved now!

1 Like