Render layers:A few questions

Hello, I have a been trying to get to grips with the compositor lately, so i have setup this simple scene below. I have placed the cube onto a separate render layer so i can add some glow to it. One issue i have is that a tutorial told me to disable ‘sky’ from the render/include tab. So how would i get my sky in the final render?, when i enable ‘sky’ i notice that the sky washes out the whole scene, but only if i have more than 1 render layer it seems:confused:

My second issue is that the ‘cube’ render layer - renders the cube on a black background, this means i have to first use a mix method that doesnt effect the whole scene someway (‘add’ usually) and second it means that the box is semi transparent because i am using a blend method rather than having the cube on a transparent background so i can just layer it on top with what ever effects i want. My plan was to split the cube layer in two, that blur one and layer them together so the cube has a glow but retains its hard edge somewhat.

I ended up just using the whole scene in one render layer, splitting it in two, blurring one, and dropping the shadows/mids to black and using ‘add’ to mix them together. here is the result.

I got the result in the end for this very arbitrary scene, but i still wanna know how to do this properly. Any pointers would be most greatful.



With this kind of compositing work, you are correct to have the box on it’s own layer with sky unchecked. Then another layer “background” with everything else (including the sky)

You then want to mix either using Z-combine (which puts closer objects over more distant objects) or alpha over (which superimposes one image over another – in this case the box over the background)

The reason to uncheck “sky” from the cube layer, is there will be a single pixel outline around the cube, the color of the sky, if you leave it checked ( unless you play witht he antialiasing settings, which increases rendertimes substantially)

Now, this allows the cube to be modified seperately (adding a glow, color mod, etc)

Right i think i got it sussed. Figured out about the alpha ‘connector’ on the render layer nodes. I will also look at alpha-over and z-combine too and see what i can do. I have also put the sky enabled on the 1rst laer and it all works out fine in regards to that.

Thanks for your help Daren!

I’ve never actually used “sky.” I turn it off quite instinctively. Just a blue backdrop hanging behind everything else the camera can see.