Render Layers transparency- Archviz denoise solution

Hello World,
I’m new to this community.
I’m using blender for architectural visualisation.

Usually I do use render layers to specify samples of grass.
In my opinion trees and grass need much lower amount of samples then simple parts of scene (like walls).
If there is anyone interested in this subject I can make a short tutorial how I’m doing this.

I found two problems:

  1. I don’t know if it is a bug of 2.67 but render layer won’t render anything for me when I’m curently working on different layer. (Strange). And keeping same selection of layer and viewport is annoying.

  2. I would love to see transparency option from “film” tab beeing able to set to the renderlayer.

If anyone knew a way for making my life easier I wold love to see some answer.
Regards!

Hi docent,

I don`t know if that helps or not… You could try to do a compositing with different scenes lets say one scene with grass and trees and one with your house or whatever…the 3rd scene is for compositing… you can setup the two layers(your first 2 scenes) to your needs and they render sepaerately with the sample settings you did for each scene.

cheers Piet

@docent,

Had similar problems as 1).
If I remember correctly: go to Render Layers icon in your Properties Panel.
Make sure in the Layers section, all the layers you want to render are selected in the Scene layer boxes of all Render Layers.
That should enable all Render Layers for rendering.

Please explain 2) more clearly. Do you mean opacity of background film or material Transparency? Couldn’t you use a mask or an additional render layer with a transparent plane?

T

Thanks for replies.
Taurelius - yep I found it… I thought that selecting Layers is enough but there is also scene box in layers menu…
I didn’t notice before this little button that was annoying me. Now I know how to use it - in my case I need to uncheck that:


So problem 1 solved.

I’ll try to explain my second problem with images. It’ll be also simple tutorial :slight_smile:

I’m using to layers to render firstly whole scene at low samples and then only objects that need more samples.
That how it looks like:


Then render them:



Plants looks clean but house need more samples >>

I have to split post because of images,
Next render layer with house, more samples and grass is masked, also checked Transparency in Film tab:


Then simple composing:


Final images :



For me it works, and saves a lot of rendering time, especially when rendering 1200 samples when plants need maximum 250 samples. Things that are problem Is as usual not perfect alpha. (It’s hard to notice if you can’t see not combined image but still).

If I could check transparency film for layer… It would be very nice.
Does anyone know how to do that?

When you are combining two images with different amount of samples it’s also advantage of even more samples.
For example I rendered background in 60 samples, house in 320 samples.
When compared to single layer render seems that combined have less noise, strange because it has the same seed.
So maybe layer should have sample seed setting also?

Can I post my proposals somewhere?
This two options could be in the same place as passes for render layer…

@docent,

Thanks for the quick tut! That is a helpful trick.

Maybe it’s an idea to use a separate ID mask node in the compositor for the grass and plant objects (using the same Passindex) instead of in the layer.
I’m guessing the alpha problem has to do with the Alpha Over node and Film set to transparent. If it ‘behaves’ like a mask node setting alpha, it will take the ‘top’ image of the Alpha Over node into account (see my post http://www.blenderartists.org/forum/showthread.php?295860-Frustrating-Object-based-green-screen-problems-Need-some-help!). This would cause the lower-sampled image to blend into the higher-sampled image incorrectly, which might cause the anomalies you’re seeing. Even worse if the difference between sample settings is greater.
When using the mask, then using Set Alpha and Alpha Convert separately this might be solved as it is more a ‘true’ alpha.

Hope this helps.

T

I’m excited because I found solution !
@Taurelius -thanks for thoughts ,I’ll check mask IDs but render transparency is important for me… I have to use it, rending hi-sample main object won’t be faster if plants weren’t transparent. But thanks for reading your post and also new Bartek Skorupa tutorial “Working with alpha edges”(- I don’t know can i post link to this site here…) I found solution.
It’s simple and also provide pretty perfect result…

Just use gradient ramp on alpha of only object layer…
See images above:



And to prove its good I used difference mixing to show how it works:


Again my node setup for mixing it:


Just move black on gradient ramp to the point you find looks good.
Looks pretty extreme but works.
Hope it’s so good for you as for me !
D.

I’m not sure if I understood everything right, in some points I can’t follow your problem (the second image of your last post looks very mixed up, it looks like some image-artefakte).
Based on the ideas in this thread I made another layer- and compositing node-setup, it seems to be simpler than yours, but maybe I’m wrong.

Please let me know what you think about it.

Kind regards
Alain

Alpha_transparency_Test_01_300613blend.zip (1.21 MB)

@Alain - thank for post.
I didn’t noticed before that by using environment pass could render something while transparent film is checked. Good to know.

However I did quick test of your scene, didn’t change anything except adding few hairs.

There is unfortunately another alpha problem. Leth call it “Alpha masking issue”
That is your scene:


It has black edge on places where building reaches evairement, same witch tiny alphas from hair…
TO compare this is one layer render:


I think that when we are using masking option it creates an alpha with is not perfect. Simple try with just cube show what i mean:


Color ramp allows to simply push black or white values- like expand. Don’t know why but in my case work 10 times better than dilate/erode. Probably affecting grey colors that erode not…
Especially good when you have some fade-outs in alpha. On your scene hairs don’t have much black border, but when you will use DOF, as small object will get blur in alphas issue will get bigger.

Artifacts that you see are only from saving jpg-s at medium quality.
I’m only affecting alpha. In difference comparison on same samples amount, I checked it does not provide any artifacts.

But again thanks for showing me that with transparent film envairement pass won’t be empty…
That should help me a lot if it will work. No more checking and unchecking transparent option. I will mix it with color ramp idea to avoid black border over house and see if it helps.
If it will work I will have a node setup for simply pushing f12 and get render :slight_smile: Gonna check it in evening and then I can share full node setup.

@docent,


I’m not sure if you actually read my post…
… setting alpha (Set Alpha node) and Alpha Convert (with Premul to Straight) separately on the render layers before Alpha Over removes the alpha anomalies. Problems occur because Alpha Over takes the background of the layered images into account (which is the mask, therefor ‘greyish’, not an actual color). (I think the slight edge in the above image is because of a very low sample rate…)

T

ThanksTaurelius

Stupid question:
When I save the rendering as a Multilayer OpenEXR and import this file into the Compositor, then the Alphachannel disapears, see here:


Can you tell me how the get the Alphachannel back to do your Compositor Node setup ?

Kind regards
Alain

Haven’t tried it, but making a guess: use a Converter node and one of the Separators (like Separate RGBA).
You get a split with a separate alpha. After that you’ll have to do something like connecting to a Convert Combine node (like Combine RGBA) without combining alpha and then use an Set Alpha node to relate the Image (of the Combine RGBA) to the Alpha (of the Separate RGBA).
Is this still making sense?! :confused:

Hope this helps…

As a wise man once said: questions are only stupid when never asked…

Hm, seems not to work.
I still get a thin outline… didn’t noticed that before.

See here (marked with red):


I’m not very familiar with the Compositor.
Any other ideas ?

Kind regards
Alain

@Alain,

Ahhh… wasn’t sure what you were trying to do…
I think the Combined in the Multilayer OpenEXR node is already… combined, including alpha set. So no need to separate and combine if you’re not doing anything separately with the alpha. I think you can just use Convert Alpha directly and Premul to Straight.
If it doesn’t work, post the entire node setup or post the blend file if you want to and I’ll take a look.
T.

@Taurelius

I sended you a pm, did you get it ?

PM-ed back.