Render locked on non existant camera position.

Me again, (Newbie)

Problem #2 of the day which has actually totally crippled me:

All of the sudden, not sure why or when exactly, when I hit Render F12 it will render an image from the same place, but NOT where my camera is positioned! I’ve tried deleting the camera and creating a new one. I make sure the camera using the angle I want IS selected (CTRL 0), when I scroll through the timeline to show the evolution of the fire in my fireplace, it does so properly, BUT from this OTHER camera angle that is NOT where my camera is at.

The only thing I can think of is that the camera is locked to a previous position for rendering, even though it has been physically moved to another angle.

Any ideas?

Thanks in advance!

Do you have keyframes on the camera? Maybe it’s jumping to a keyframed position or rotation.


I’m not sure how to check for that. I went to the animation window, clicked x and selected Delete KeyFrames but it said there weren’t any… I can render F12 at different frames on the timeline and it adjusts the amount of smoke and fire in the fireplace, but the camera remains in this position despite the fact that its actually been moved and pointing in a completely different angle. Attached is a screen shot of a rendered frame.

Not sure if this is related but I think at about the same time as this started all my textures stopped showing up in my regular views.

Very frustrating. Another issue I’m having which I posted earlier is that it only renders animation up to 50 frames and then just duplicates Frame 50 for the remaining 150 frames of test animation. Unclear whether this is all related or not.

Thanks for your help! Any other ideas?

Attach a blend file!

You could also try restarting in the form of… start a new .blend file. Then SHIFT+F1 (opens append) navigate to your old blend and import the scene folder.

edit- or open up the dope sheet or graph editor and start deleting things in there as you troubleshoot the problem.

I had the below written and tried uploading the 70MB Blend file but it goes through an upload period and then nothing… doesn’t show up in the attachments window. Not having a good day here…

At least 3 issues I’m having with this at the moment:

  1. Renders alway from same location regardless of camera placement but does take frame in timeline into consideration.
  2. Renders animation only up to Frame 50 then duplicates frame 50 for remaining 150 frames it’s set for.
  3. All materials seem to have disappeared from the objects unless rendered.

Attached is the file… keep in mind I’m a live action filmmaker, this is my first week with Blender and only played with Animation Master for a bit years ago - but not well! So apologies for stupid mistakes.

I’ll try your suggestion of opening a new Blend file and see what happens…

OK… Dope sheet is clear… nothing there.

I followed your instructions opening a new file and loading the appended scene…

Results are that the resulting scene is NOT the scene I had. Its missing more objects and modeling I had subsequently done but… the camera issue is fixed BUT I still have a lack of materials showing but have experimented and can delete the textures and re-apply them. They still don’t show up until rendered but… don’t know which way to go at this stage. I would have to remodel a lot of stuff I have done in the other file. Not sure why its loading a different Scene file when there is only one to chose from…

I’m confused…

Found a work around solution:

From my original scene with the problematic camera render, I clicked the + to create a New Scene and Linked Objects.

This gave me my scene as was before but with a working camera a few glitches - all navigation movements were reversed, i.e. move up on track pad was move down of scene etc etc… annoying but I’m sure I’ll find the fix somewhere. Also my textures had to be reapplied and my fire is generating but not rendering… Tomorrow’s head aches. Glad I got the camera render fixed.

Thank you all. Still have a fire render issue in another post if anyone wants to give it a whack. I’d still like to know what caused the above issue if anyone knows - for future reference…


This issue keeps recurring every day or so and I have to keep creating a new scene to work around it. So if anyone has an explanation and easier solution, I’d be very grateful!

Try and look at the Scene panel of the Properties palette, and verify you have actual camera set as camera.

Just a try

paolo

Paolo, thanks… I do… I’ve even tried deleting the camera and adding a new one making sure that it is the selected one… I still get a render from an old position.

Try deleting all cameras and shooting to see if you come up with a black frame or if it refuses to render at all. If the camera is locked on to something, it’s pretty much going to either be an IPO, or a track-to constraint. If the shot seems to go to frame-50, you probably do have an IPO (keyframe) there, and maybe the length of the shot in frames is not what you expect it to be.

If you use the OpenGL Render buttons on the 3D window that is set to “camera view,” you should see exactly the same thing, but it’s much faster to produce. (In fact, as a point of general technique, that’s probably how you should be doing all shot-setup until you get to final rendering. Turn on the “Stamp” feature and you’re back to very familiar live-action filmmaking territory.

^^^sundialsvc4’s suggestion reminds of another good way to trace what’s going on. Play the animation in the 3d window, but from something other than camera view (top, side, or quad). Watch the camera to make sure it’s not doing something unwanted.

You should also open the camera in the Outliner and examine everything that’s attached to or affecting it.

Thanks for the input folks. I can’t do all the tests you suggest as I recently deleted the latest offending scene after creating a new one from it Linking Object Data - my usual work around this issue. I have confidence this will occur again and will then do some of what you suggest. That said, some of your suggestions I already did.

There are no key frames. This was occurring when the only thing happening was a fire effect. But I checked and in the dope sheet selected all and deleted only to be told what I could see anyway, that there were no keyframes to delete.

As for what keyframe I’m at when it occurs - doesn’t matter. It will render from the same position and keep the keyframe I chose. Funnily enough the flames adjust to the keyframe chosen. (at least in one test)

It’s like something OTHER than the camera is set to be the camera but it coincides exactly with a recent camera position. I go though the outliner and there are no additional cameras listed. I did a render after deleting all the cameras once and did get the same render. What stumps me is the coincidental exact placement of the render from a previous camera position.

Re OpenGL Render Buttons in 3D view… I usually just hit F12 though I may have hit those to see what they did at some point.

Sundial - I do most of my stuff in camera view, occasionally switching to Ortho views. So you’re saying I should use the render buttons at the bottom of the 3D screen instead of F12? I’m a bit confused about what those are for. I hit them and the camera icon gave me a Black screen with outlines of the lights. When I hit the movie render icon it started to generate the fire effect but the rest of the scene was black and again, all I could see were the light outlines (dotted lines) and the fire.

No idea what the “Stamp” feature is or where I would activate it.

Did I mention I’ve been learning this for less than 2 weeks? ;-)) SOOOOO much to learn!!! (So little time…) But I love it! It’s like live action filmmaking but with no limitations - except for my ignorance in the software and tricks of your trade! Ha!

Thanks for your patience guys (gals), its appreciated.