render object & hair - object not visible

Hi,
I finally got the balls and started to learn blender for the last two days. I’ve never done anything 3D, so I’m totally blown away how amazing it is, things slowly start to make sense. :cool:

I’m learning about particles right now. I’m trying to add a hair to an object. Everything seems to work fine and I can see the hair in object & edit mode, but when I render it, only hair gets rendered and the object becomes invisible. If I hit ctrl+z and remove the hair and hit render again, my object gets rendered. Why is this happening and how can I make my object visible with hair? Thanks!

in the visualization tab - click Emitter

I have blender 2.45, I couldn’t find visulation tab, so I installed 2.49 and clicked ‘emitter’. Now I see the hair in object/edit mode, but when I hit render, only object is rendered. If I ‘uncheck’ the emitter, nothing is rendered.

I noticed there are two buttons under Particle System tab, ‘Enable Particle System during rendering’ and ‘Enable Particle System during interactive display’. Both of them are clicked.

Any guidance please? Thanks!

maybe you have the particle material set to render the wrong material
or it is set emitter not hair
or you have baked the particles (might need to release the bake)

dunno?

here is a blend
see if this renders

you can also post your blend so we can see what the problem is

Attachments

HairRENDER.blend (540 KB)

Your file worked! I tried to setup the same particle settings for mine, but it still doesn’t work. Here’s the link to my blend file (it was too big to attach)

http://riffoholic.com/skull.blend

Thanks!

Your file worked perfectly! I tried to setup the same particle settings for mine, but it still didn’t work. Here’s my blender file: http://riffoholic.com/skull.blend

Thanks!

Your file worked! I tried to setup the same particle settings for mine, but it still doesn’t work. Here’s my blend file: http://riffoholic.com/skull.blend

Thanks!

I’m new to Blender as well, and was having the same problem.
Instead of having the particles emit from the object you want rendered, create a separate object to emit them. Seemed to work for me.

Rendering objects particles seems to be broken in v2.49a and 2.49b. It works in 2.48a.

found the problem

you have multires active

switch it off and it works fine

(sorry It took me so long)

Well, in my own file, I use for my particles a very simple mesh made of 6 faces, and no multires, and my particles are not rendered !

I have made a very simple file with only an emitter and particle objects, and they are rendered. But in the original file of my current work, it works in 2.48a but doesn’t in 2.49a an 2.49b.