Render problem / Cloth tearing apart fx with particle system

I made a animation for flag which is tearing apart. But i can’t render it. I view clear render in 3D viewport but when i render it it looks like this which you can see on picture. You can also see my modifiers. It works correct on viewport but not in render. (I rendered both with cycles and evee) And there are shape keys on flag to simulate flag movement. When i close cloth modifier its ok but when i open it…

Anyone help please?

I know for sure this happens when the renderer has more/different vertices in a simulation than the simulation has.
I have the same issue when I have a subdivision modifier before the cloth simulation, and its viewport subdivisions are lower than the render subdivisions.
So this looks pretty much identical, but of course, you dont have a subdivision modifier.
In the case of the subdivision modifier, Its because (i assume, i have not looked at the code) its animating vertices based on their ID, but then once its subdivided, all those ID’s are in the wrong place, so everything gets all jacked up.
I can only assume one of your modifiers must be creating/changing vertex ID’s separately in the renderer than it does in the viewport.
Have you tried disabling them one by one and rendering to see if that fixes it?
Also. Why do you need both shape keys for simulating flag movement, and a cloth modifier?

edit: oh and make sure its baked. Simulations in blender 2.8 tend to get completely fucked up in the renderer if you dont go to cache and bake.

1 Like

Hey thank you for answer. That makes sense that id thing. But i cant find anything i tried to disable modifiers one by one. Just when first 3 of them are enable at same time, this render problem will occur. But i need first 3 of them to create this animation. Shape keys are for waving animation for flag which i did before all of these. And then i needed second cloth modifier so i baked first one of them as shape keys. So second cloth modifier is for just for animating this flying parts.

Actually after my research i believe this is ID problem as NiklasWerth’s said. And the problem is about “shape keys”. They cause that problem. I couldn’t figure it out how to fix this problem but i found that video that might help some people about their issues.

Had to go to work, you know how it is, sorry for the late reply.

So i believe I have fixed it.

Cloth modifier first, with a baked animation so we dont have to worry about any shapekey stuff.
Then we have our particle and explode guys. now, unfortunately because of the limitations of the explode modifier, this might not look as sexy as we want it to, but its got no artifacting atleast thank goodness.

So if we want a really nice result, we need use an addon. We can either go back to 2.79b and take advantage of the fracture modifier addon.

using the technique outlined in this video.

Or we can spend a sizeable sum ($40 which is a lot to my poor ass) for ClothFX which is specifically for cloth tearing effects.

1 Like

Wow thank you so much. That looks great. But when i try it it doesnt work for me. Can you also share your settings for cloth and particle? What am I doing wrong?

Ill do ya one better and just upload the file so you can check it all out yourself.
cloth flag stuff test.blend (1.5 MB)

1 Like

Thank you so much for your effort. This will be very helpful. Appreciate.

1 Like