Render problems

I’m trying to render in Cycles, but CPU is just too slow for me. I recently watched Andrew Price’s city tutorial and saw him go to User Preferences and change the compute device in the System Window to CUDA, but I only see none on mine. Why is this?

What graphics card do you have ?
The option will only be available for compatible NVidia cards
http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/GPU_Rendering

Well, there’s my problem. I have an AMD Radeon HD 6250, not to mention that it’s a laptop, so I can’t really change it.

Is there any other way I can speed up the renders?

Thank you very much. I think that thread will solve most if not all of my problems with Cycles.