Render slider for hair children does nothing

  Hi all! I've been using blender for about a year and a half now, migrated from maya; I recently started to play with the hair particles and bumped into an issue; I create the hair, all is good, but in the children rollout when I switch to simple or interpolated, the render slider does nothing when I render with cycles; for the children to show in render I need to set the display value but that means that my scene in the viewport becomes heavy; I only want to increase the number of children in render, but it doesn't do anything; is there something I'm missing, I've been struggling with this for quite a while and I haven't found a solution yet; thank you very much for your patience and much appreciated, all the best!

You mean the children counts? Display vs. Render? Well, actually they should do what they say. If you provide a blend file, I can check if there is something wrong with it.

Hi, thx for the reply; exactly, the render option doesn’t do anything when I render; to increase the number of children in render, only the display option works, but that means that it increases the children in viewport, also; unfortunately I can’t upload the scene, 'cause I’m a new user and it doesn’t let me; but the scene was very simple, just a sphere, created some particles, switched to hair, only let a few particle strand to see the effect more clearly, interpolated method, switched the display to 1 and render to 500 or whatever, when I render I just get one children for particle strand; I also tried in version 2.80, same thing, I just don’t know what could be; thanks a lot for the trouble, cheers!

Honestly, for me it works as expected. The display slider controls the number in the viewport (including viewport in rendered mode), and the render slider controls the number for F12 render.

Can you try this one:

hair-counts-test.blend (541.5 KB)

It should work. Is it the same what you are doing?

Hey, thanks for taking the time; I opened the scene but, again, just one child per strand, display slider being set to 1, no effect for the render slider, whats so ever, when I render; guess it has something to do with my system, don’t know, gpu or whatever, but it’s really strange; maybe if I remove the preferences or something it will work, I don’t know what choices do I have honestly, but thank you for taking the time, really appreciated!

Just to be sure, you try F12 render (not 3D view in rendered mode)? I take it, you are rendering on GPU? I have seen a few kinds of glitches with that over time, with different versions of Blender and drivers. Does it make a difference to switch to CPU rendering?

It works, when I render the final image, it shows the children, how it’s suppose to; but shouldn’t it also be working with rendered mode in viewport, I mean I don’t want to always render the image, I want to work with the render buffer, so I can preview it, in real time; is it possible? thanks alot, again! :slight_smile: