Render Test Error - Blender 2.5 HDRI

Hi There, my first post! I have been animating for over 10 years now, initially started on Lightwave version 4.0 years ago then switched to Maya 4.0 also years ago. I have been keeping an eye on Blender’s development over the years and started playing around with it at version 2.48. I am now testing out version 2.5 and I must say that I am really really liking it!

Thank you so much to all the people developing Blender it is really shaping up as a true Maya contender! So much so that I want to switch completely over to Blender from Maya. I still use Maya heavily in production from day to day but I am trying to learn Blender and bring it in to my workflow.

Ok, the reason for my post! I am doing some HDRI render tests and I am getting unusual artifacts and glitches in my renders. (I will try to attach an image to this post). I know this could be a result of the render engine not being fully sorted yet, but if someone could shed some light on this I would be greatly appreciated! (Look for the black spots)

Cheers,
Paul

Attachments


maybe you can attach your .blend file?
Those black spots look round, not square like what you see with flipped normals and doubled vertices.
Maybe someone else knows.

No, those are square. I don’t know what causes them, but they are artifacts. Do they only show when using HDRI backgrounds, and how is the .hdr set up?

Can you upload the .blend file ?
I think we can see where the problem lies if we try to render it using Blender 2.49b. Default settings may be different (Like specular and intensity) but the black dots may disappear. And you have to do is comparing the settings between the two versions :wink:

Hi Guys, thanks very much for the replies!

I have attached the .blend file.

RE: “Do they only show when using HDRI backgrounds, and how is the .hdr set up”

Yes, I’ve done quite a few renders without HDRI and it has all been fine. I’m not sure if I am setting the it up correctly. I can find little documentation directly related to 2.5 on the basics of setting up HDRI in Blender 2.5.

RE: “I think we can see where the problem lies if we try to render it using Blender 2.49b”

I’ll give that a try!

Thanks again!
Paul

Attachments

HDRITESTartifacts.blend (520 KB)

Hmmm … very interesting. I downloaded a newer build (blender30198-win64) with OpenMP support and got some interesting results. I opened the same scene in the newer build and it rendered fine!

The only difference I can see is the sections/chunks that are being assigned to each of the processor cores for rendering. (My machine has 8 cores and 12GB ram).

In the first pic you can see that more smaller strips are being rendered with the standard 2.5Alpha2 build. This is the build that is introducing artifacts.

In the second pic. This image was rendered with Blender30198-win64 OpenMP and larger chunks appear to be assigned to the processor cores (I understand the OpenMP means Multi Processor support, please correct me if I am wrong) and everything is rendering fine!

Cheers,
Paul

Attachments



I guess it was the state of development at the time you rendered. I rendered this on a recent svn -r 29924 on linux. I believe it also has OpenMP enabled, though only two cores, so it looks the same while rendering.

It looks clean:-


I would have thought that more, smaller strips is right though, as your machine should be using 8 cores. Perhaps the larger chunks are 4(or more) thin strips?

8 cores… nice :slight_smile: may i ask how many ghz?

I tried to download the new branch builds for the mac. Unfortunately they don’t render at all, as they cant support lights!!! My decision is to wait for an only official build for the mac. Graphicall is for those who want to loose time. These don’t make me feel creative at all. BTW the official build full supports my 8 cores 16 threads machine and its extremely fast when rendering. When calculating AO only one thread though, pity. All 2.5.x builds suffer from not having a decent obj importer !!! 2.49b is overall a better app.

What are you talking about here? The intel mac builds (I am the builder) on graphicall.org most certainly do support lights.

Hi Natholas, It’s a Supermicro Workstation running Intel Xeon CPU’s E5530 @ 2.40Ghz.

This is my second Supermicro workstation, gets worked hard day and night. Super reliable!

What are you talking about here? The intel mac builds (I am the builder) on graphicall.org most certainly do support lights.

Hi treatkor the branch [30309] build 32 or 64 build has this particular problem, no lights rendering, values of lights look crazy, only AO and this with green colors quadrangulated effects etc. On a mac pro 2xeon nehalems. All other builds from you are working fine. Well almost, some minor bugs here and there… If there are problems with prefs etc, I really don’t know. I can wait though. Meanwhile the approximated GI is not a solution for me. Its unpredictable in different topologies, especially inside openings, like mouth, eyes… The combination of SSS and GI is really important to me (most people believes that these don’t work well together).
http://blenderartists.org/forum/showpost.php?p=1661780&postcount=8

nice :slight_smile: thanks… im normally using a 2.4 quad and that renders crazy fast compared to the duel core imac i used to work on… cant imaging 19.2 ghz :stuck_out_tongue:

Hi Natholas, the 2nehalem 16 thread at 2.26 is even faster. The problem is when calculating AO. Its an one thread calculation you see. Check it using activity monitor. After this and asking an 64x64 rendering performance, it comes like a thunder some seconds I mean. Unfortunately one thread on xeon means 2.26/2 = 1.13 Ghz