Render the shadow, but not the object casting it?


How can I draw the shadow of an object, without drawing the object itself? If I set it to ‘OnlyShadow’, the shading of the object is still drawn. Selecting ‘Shadeless’ does not seem to do anything.

Thanks for any help!


Set the alpha to zero in the object’s material settings.

That was the first thing I tried, but then the shadow isn’t drawn either. :frowning:


Turn on ztransp, turn off specularity, set alpha to zero.

OK, I figured it out. I was using ray tracing, so when I set the material to be perfectly transparent, the raytracer figured it should cast no shadow. By putting a spotlight, and setting it to bufshadow, I got the wanted results.

Thanks for your help!


It could’ve also been having the transparent shadow button checked, because with that checked the shadow adopts the transparency of the objects.