Render window is now forced to be on top of main window?

I just updated to 2.93, and there is a new behavior that wasn’t present in the past.
As the title says, when I render, or use the “view render” menu option, the new window that pops up is now forced to stay in front of the main blender window. This means I can’t keep it open and switch back and forth any more. If I want to do anything with the main blender window, I have to close the render window to get it out of the way, then re-open it when I want to see it again.

It used to just act like any other window, without any of this always-in-front behavior. Is there a way to turn this new behavior off? I’m not finding any obvious option to do so.

I guess I can live with it, but it’s kind of annoying, and a seemingly unnecessary change.

Yup. Very annoying. Most annoying is I can’t alt+tab from the render window to a different program and back, it always includes the main blender window in the alt+tab history so I wind up back at the main Blender window instead of the other program I wanted to see.

I didn’t know that (haven’t rendered anything with 2.93 yet) but I found it annoying enough when they decided Blender would always open full-screen on my main monitor. They keep taking options away instead of getting a proper UI designer to make things user friendly. (sigh)

Blender Preferences: Interface: Editor: Temporary Editors: Render in: New Window| Image Editor| …

(since 2.8 i believe)

@Okidoki Unfortunately that’s not the solution. What I’m trying to get is the old 2.8x behavior of rendering in a new window, but not having that window stuck on top of the main blender window.

Also IIRC that is a per file setting, not a global one.

With the “…” i meant: have a look. Render in: set to Keep User Interface doesn’t pop up anything and if you have a second window opened with image editor showing the Render Result it’s just updated.
And sorry but for me the settings in 2.8 and 2.9 only with New Window do a pop up, but this is not modal. Do you have set Render → Lock Interface on (this is not the default) ?

This behavior (as any other in the preference) can be saved and then would be your new (global) default.

I too have noticed this and wondered why they made this change.
It’s documented in the wiki
https://wiki.blender.org/wiki/Reference/Release_Notes/2.93/User_Interface

This may have something to do with it.
“Child windows are shown on top of parent windows. You can now work with overlapping and floating windows”

My workflow is: I render something, and leave it open. If I go to another application (chrome or something) and come back to blender (alt-tab or the taskbar), the render window is there and I cannot access Blender until i minimize the render window.

What’s even more confusing is how it behaves with these steps:

  1. Open blender, hit F12. (set to render to new window), render window takes focus.
  2. Go to another application
  3. Click on blender task bar (or alt tab to Blender) It will show the Render window.
  4. Minimize the Render window.
  5. do something in blender.
  6. Click on the Blender task bar to minimize it.
  7. Go to another application
  8. Come back to Blender and guess what. The Render window takes focus and you have to minimize it again.

The steps above may seem convoluted, but that has happened to me several times. There are some situations where i have to click the render window 3 times to minimize it to get into Blender.

I believe the underlying problem is the render window is no longer a separate Windows window. it’s a child of Blender and takes the always on top approach.

in 2.91, do the same steps i laid out and at step 3 you’re working in blender immediately. I’ve tried to adjust my workflow and be very vigilant of that render window. FYI I skipped 2.92.

@Okidoki
No, I do not have “lock interface” enabled. I do have “Render in” set to “New window”, as I did before.
image
image

These are the same settings I had before in 2.92.

Other windows, like the preferences window, are also now perpetually above the main blender window. I can find no way to keep a pop-up window open (like preferences or image editor) and not have it in front of the main blender window.

Previously you could alt-tab between them, and they would behave as expected for separate windows; you could have either on top of the other, and the active one was always on top.
In other words, you could keep a render window open after a render, and alt-tab between it and the main blender window, without the render/image editor window covering up the main blender window.

This behavior was not present in 2.92. It only started happening in 2.93.

If this is the case, then that is the crux of the problem. If I understand correctly, that would mean there’s no way to change this behavior. Is that right?

This whole thing seems like a dubious design choice, and one that unnecessarily breaks workflows.

There were a lot of changes to how windows are created / saved / loaded / etc on the Windows platform for 2.93.

Basically windows could be created on the main monitor, but not others. Then if you moved that blender window to a different monitor then open a child window, like “Properties” it would also go the wrong place. Save your blend with multiple windows spread over multiple monitors and when you opened them they would be in the wrong place.

So with 2.93 almost all of those types of multi-monitor placement problems should be fixed, with just a couple of exceptions. If you arrange multiple monitors in a vertical arrangement requires a fix not yet approved. And if you have multiple monitors of differing scale they can sometimes be misplaced by a few pixels, with another patch to be approved.

Another change, a bit related this thread, is that we always had complaints on how multiple windows were not grouped on the taskbar. So it was hard to minimize a entire group of multiple windows at once. As part of that change Window / New Window was changed versus Window / New Main Window. New Window now gives you a simpler window (with just a single editor) that is a grouped child, while a new main window is separate parent that can create its own children grouped with it.

Another change is to how “temporary” windows are created. It was a long-standing complaint that temporary windows (Properties, Render, etc) could steal space from others. So if you had “Properties” open then a new Render window would just take that over. That is fixed and shouldn’t happen now.

The main complaint in this thread is about child windows. We have had, forever, bug reports about users who would lose windows behind others. They’d complain of bringing up “Properties”, click anywhere else and have no idea where their window went as it dove behind. So now Properties is on top, but you still have the option of minimizing, maximizing, etc.

A nice side benefit to this, for Windows users, is that we can now finally have proper floating windows. So in version 3.0 we can now right-click on any area header, select “Duplicate Area into New Window” and get a proper on-top window, which was also a longstanding complaint. Although it would be nice if the original area closed, but that is a different proposal.

I personally have no issue with us going back to having the Render window be non-owned, so it would behave like before. But it would have to be considered along with the potential downside of it not being “on-top”, so some users could lose it. And it would also not minimize when you minimized the main window.

1 Like

@Harley
Thanks for the detailed explanation. I think I understand.
So basically the new behavior that I dislike is a consequence of making a lot of other things about separate windows behave in a more desirable way. And basically it’s set that way and not about to change.

I didn’t have any issues with the older way that multiple windows were handled, but I can see the point. And one person’s preferences doesn’t determine how the UX/UI design should go. Oh well. :slight_smile:

No, it could definitely change.

We could easily make just that one window, the “Render” one, be like before (not owned by the main blender window). But just as before, it could be lost behind the main window accidentally so we might (?) get complaints from users who do that. And minimizing the main window would not minimize the Render window along with it.

Its really just a matter of balancing those considerations and the competing needs of different users. This is a change, but mostly from adding in more support for users who use layouts that span over multiple monitors.

Thanks to both @Harley @Tokamak for a constructive discussion on this. I feel like I better understand this issue, or to put it more eloquently, “behavior change.”

I’m pretty much in the same boat as Tokamak. I never had any issues with how the multiple windows were handled. But I get the point of why this was changed.

I guess if I could expand a bit on why it feels awkward in 2.93. It’s the Windows taskbar experience.

In Blender, if I render, there are now two windows task bars. “Blender” and “Blender Render”.
If I go to another application, and then come back and click on the first one (“Blender”) it shows the Render window. Multiple clicks doesn’t do anything. It doesn’t minimize Blender. As a Windows user I expect something to minimize when i click a taskbar item again.

Okay, so then I click on “Blender Render”. It minimizes and now I’m in Blender.
Here’s the part where it gets really weird (at least as a lowly Windows user):
I click on “Blender”, Blender minimizes completely. Then there is only one taskbar item called “Blender”. When decide to go back into Blender, and click on it, there becomes two task bar items again (“Blender” and “Blender Render”). And the Blender Render window is in front.

This is all very nitpicky on my part, but there are some new rules I need to remember:
If there are two taskbar items and you’re not in Blender, clicking on “Blender” and “Blender Render” is the exact same operation.
If there are two taskbar items and you’re in Blender, do not minimize “Blender” from the taskbar. Just don’t do it.

I guess a fix would be to make the exception for the Blender Render window to avoid all these new changes for 2.93. Or a preference or something. Every user wants a preference, I know :slight_smile:

Oh and maybe I should explain why having the “Blender Render” window open all the time is important to me. Because it renders too big and i have to zoom out to see the whole image. And it doesn’t remember that size if I escape out of it and F12. it renders huge again. I keep that window open because then I don’t have to resize the window everytime I F12. Maybe if that size setting were remembered, I’d escape every time and none of this would even be an issue anymore.

Thanks again everyone for listening!

The window behaviour I don’t like—and I’ve lost track of when this started—is Blender always starts up in a maximized window on the main screen. Sure, there should be a way to ‘rescue’ a lost main window if it gets pushed off screen and can’t be recovered by normal means, but IMO, this wasn’t the way to do it.

Yeah, I don’t like that either. I didn’t break that though, as I see it happening in 2.91 as well. LOL

I’ve had issues with the Preference window always being the wrong size. However, I just checked and the 2nd window on my second monitor indeed comes up as I set it, when I saved the appropriate Startup file (File/Defaults/Save Startup )

I think people need to be more cognizant of using the DEFAULT STARTUP file to set user params: for instance, it wasn’t immediately obvious to me that the Outliner checkboxes could be set by setting them as preferred in an empty file, and then saving it as the Default Startup. You can also establish a number of default Scenes: eg I like to have one Scene named SCRATCHPAD so there’s always somewhere to test things out. I have SCRATCHPAD and MAIN as two permanent default scenes.

“always?”

I make my window exactly the size I want it, move it onto my third monitor (not main), and place it exactly where I want it. I then select Window / New Window and place this new window on another monitor (also not main). I then select File / Defaults / Save Startup File. The next time I launch blender I get those two windows on those non-main monitors in exactly the sizes and positions I saved them at. I have nothing on my main monitor.

I was going to say… I think the window dimensions and location are saved on a per-file basis, so setting it in the default startup file ought to do it. I know that when I have a file with multiple main windows on different monitors, everything always restores correctly when I load the file.

LOL! Wow! And it used to be automatic. Silly me. Trust Blender to get this complicated when all it took before was get the window where and how you wanted it, then shutdown and restart and boom! Just like any other Windows application.

Okay, I stand corrected. At least that’s far simpler than opening extra windows and all that jazz. Still, up until not that long ago, it was unnecessary to save the window as un-maximized in the Startup file.

Good tip. Thanks, Tokamak!

Could we have an option in the menu of the render window to toggle “always on top” mode? There are times when I want it, there are times when I don’t. This is one of those scenarios where I prefer Mac OS ability to alt+tab between all windows spawned from a single app instead of between all apps.