Render with unwanted Artifacts

When I try to add materials to the objects I have created in blender I get these artifacts that look like dots of lights all over the object. I certainly did not put them there but they show up when I render and when I use the render function in object mode in blender. I am using cycles to render. Blender is 2.70 version. Computer is a Mac running 10.9.2. It does not seem to be specific to the OS as I have rendered the image in blender on Win 7 with the same result. It seems to happen a lot when I make materials. What am I doing wrong?


What are your render settings ?
How many samples are you rendering ?
GPU or cpu rendering ?
What lighting do you have in your scene
Material details etc ?

Here are my render settings…

I set it for 40

I am not sure. How do you find that information? Sorry I am not an expert at Blender…

Here are the materials…

40 samples is an order of magnitude or two too low.

He’s got sq samples enabled, so 1600 samples, which should be enough.

set clamp direct to be 10 or so then lower it if you still have problems. setting it to 1 will remove all of those dots but it’ll mean ( i think) that no pixel can have a greater value than 1 hence meaning that you will lose detail in highlights when compositing.

So it is. Time for me to get another eye exam. :stuck_out_tongue: