Rendered Image doesn't match rendered view

Hello. I am fairly new to blender and am having problems lighting and rendering in my scene. When I press shift and z (rendered view) the scene renders correctly. However, when I actually render the image, parts of the image are incredibly distorted. Specifically, on the table and around the lamp in the scene. Here is a link to my file.
Attached is rendered view and the actual render.

Let me guess: You’re using the denoiser?
Blender’s denoiser can only do so much and certainly is no magic bullet to fix all image issues. If you apply it to an image with too few samples all kinds of artefacts can occur.

You will have to render with more samples and - preferably - get rid of those fireflies by optimizing your scene.

Yup. I noticed this earlier and disabled the feature. Rendering without it and with high samples seems to do the trick so far. Thanks :slight_smile:

I suspect there’s a glass shader or a highly reflective surface in the lamp that is sending caustics all around the scene. Fix that and it should render fine. Do keep in mind this is a poorly lit indoor scene, so it will require a lot of samples even with the denoiser. Also make use of the clamp indirect setting. Good luck.

Your scale is off the charts. Light pole is like 1399 meters tall. Scale down the scene to appropriate scale and reduce the lighting lotsfold :slight_smile:

Ignoring the light from outside (I disconnected world), you have a fairly large area light and a small bulb - big and small tend to never work well together. Unless you crank up the samples, the only way I can think of to help out is to render them out separately (and clean them up) in separate passes and add them together. Rendering the bulb in isolation, you’ll still get a lot of noise from it since it (other than the table) only delivers indirect lighting. A cheap/cheat way to fix this is to drown the noise in good lighting - it’ll still be there but overpowered by the good stuff and as such pretty invisible.

Also, use a spotlight rather than a spherical bulb to do the emission unless you have good reason to use mesh lighting. At least for now, lamps clean up faster than geometry based lights.

Lamp vs mesh (in isolation), 100 preview samples, no world, and scaled down:

The object called “lamp bulb” is also problematic. Don’t emit light from a volume inside glass. Ignore the filament stuff and let the bulb itself be emissive if doing it this way. If you had something in the scene requiring such a low exposure that the filament was visible, it wouldn’t do much at all wrt lighting the room (would be far too dim).