Rendering a White Scene? ( Help please )

Ok, i am looking for some advice, i’ve got a scene i am trying to render. I will be adding other models to this, but at the moment i am trying to set it up.

Here is a test render:
http://img424.imageshack.us/img424/8951/testrender1kk.th.jpg

Now obviously this is a poor attempt, but its just to show what the scene is like, here is a wireframe too on that subject:
… Ok aparently i flucked up… somehow Blender didnt ask me to save, it didnt save, nor did it save any backups… thats what i get for using the new version lol.

AAnnnyyyway, ok, look at that render. I didnt attempt to whack awa at a bunch of techniques because i could never do it before when i was into blender… and its been a while.

You know those commercials with a completely white scene except for something there? A box, a person, w/e. Well i want to do that. Infact it will be blended into a white background so the image has to give the appearence of depth but still be 100% white as to blend perfectly with the white html background.

So ya… hopefully you understand.
Now any idea how this can be done? Is global illum the only way? Because every type of render i’ve ever done i havent been able get a scene to be completely white without overflooding the object(s) in focus.

Any idea how this can be done?

Sorry for the sketchy descriptions… i’ll be searchin on the net for a picture, but people often do similar renders with GI but its not completely white. Any help?

From the F10 panel press the ‘RGBA’ and ‘premul’ buttons and change the image type to something that supports alpha-channels (png or targa for example). Now when you render your scene you get a see-through (alpha) background that lets any color (white in your case) through.

If you want to keep some shadow, use a material that has ‘only shadow’ set (materials panel).

Another option is to make the base plane an “Only Shadow” plane (check Only Shadow) on the material panel and then on the world panel change the world color to white.

somehow Blender didnt ask me to save, it didnt save, nor did it save any backups… thats what i get for using the new version lol.

If you make modifications, Blender always saves file called quit.blend. A message appears on the console. You may need to help it by setting a valid path in the User Preferences.

I use that method. For some reason it doesn’t work properly if I use lights with buffered shadows. Also, if you need to adjust the shadows cast on the shadow-only surface, you can adjust the alpha of the surface. I found I needed to do that because lights that don’t cast shadows didn’t affect shadow-only objects whereas they the shadows if shadow-only is turned off. I don’t think that ought to be the right behaviour. I haven’t tried it recently so maybe it has been fixed.

I’ll be tryin this soon… which i’ll probably have questions about. We’ll see. Thanks!

Ya, thats what the problem was. I assume. I didnt make a temp directory for the file.

Thats what i was lookin for, thx!

The other method i was more afraid because the alhpa invis depends on the users ability to view it properly. Not that many people can’t see TGA but still, for web based it seemed odd.

White Globe and Only Shadow plane works perfect!

On a side note, GI is YafRay right? Thats with the whole ORB thing you make around the object, blahblah, what was the Blender version of GI called? Ambient Occlusion or somethin?

yeah ambient occlusion makes the whole image a lot whiter. its in World buttons.

Ah! A white scene.
I use this method a lot.
Such as this (weekend challenge sample)…
http://workingweek.org/still/DROIDS.jpg
http://mysite.verizon.net/vze3nvj6/Blender/forum/DROIDSth.jpg

With Blender’d rendering engine, Ambient Occulusion works great for this. In Yafray, of course, you already have ambient occlusion. For the best effect in YafRay, use the “best” or “highest” settings, and do not use CACHE if you want to achieve a very realistic look. Using Cache is good for quick renderings, but for great scenes like yours, don’t use it.

I change the world color to WHITE. And almost always use an AREA lamp with 6 or more samples (softens the shadow edges - More samples = softer edges). Make the AREA lamp large, to cover a large area.

Well YafRay aparently doesn’t have a OnlyShadow setting for materials so i cannot use it. I mean that scene of yours is white, but not fully white. This kind of thing i’m talking about would have to fit seemlessly in a white background and only the main objects can be seen. … and their shadows, etc.

You can do it, my particular setting was what I wanted. You need to change the settings and the shaders (ans “Emit”) to get that white look.

You can do it, my particular setting was what I wanted. You need to change the settings and the shaders (ans “Emit”) to get that white look.[/quote]

Can you give a little more guidance/directions for a YafNub?

cuz it needs to be 100% white to match a white html page. No “edge” on the image if you will.

ie:
http://img224.imageshack.us/img224/9021/mircattitlev010ec.jpg

Like this?

http://mysite.verizon.net/vze3nvj6/Blender/forum/white.jpg

Here’s the BLEND file…
http://mysite.verizon.net/vze3nvj6/Blender/forum/White.zip

Hey i lov you :slight_smile:

Now time to play with the blend and see if i can decifer it hehehe :slight_smile:

The main thing that I did was change the “EMIT” setting for the floor. Turned down the shaders for the floor, for no shine. Turned up the REF for the floor to full (1.000).

You can use any lamp. I used a spot lamp to make it simple.

I notice on the GI Tab there is differences, are those required?

Cuz i am kinda mirroring your’s step by step, but atm i have achieved the white floor. Emit is up, Ref is up, maybe the shaders is the problem

Ya it was the GI, without the GI the unlighten parts of the floor were dark.

So i’ll have to deal with that :slight_smile:

Any advice on producing a small soft shadow?

Notice the following image, there is GI ( to get the white ), and a soft spotlight.

http://img363.imageshack.us/img363/5703/mircattitleyafv013xk.th.png

However i cannot seem to get any lights to be “only shadow casting” or get a light to produce a shadow without completely flooding the object.

Its a little too light, but overall i like it. But again, theres like zero shadow. Any advice? ( seems anything i knew from Blender Internal has changed in Yaf lol )

Anyone? *bump