Rendering camera movements

I am new in Render. I am doing an animation of a camera moving in a landscape. I used the IPO Curves window. When I press alt-sht-A the 3d animation looks fine in the 3D window, but when I am rendering the results are different.

At the begining I am doing a zoom-back and then the camera moves arround. The rendering shows the zoom efect, but not the movement of the camera. The final result is the camera doing the zoom and then it is static during all the animation.

I am using AVI Jpg and AVI Raw. I pressed ANIM button, and the frames ranges are Ok. I am using curves for position and rotation of the camera, a curve for the camera lens, and a time curve.

How can I do a render of camera movements? I am doing something wrong?

Thanks

It sounds like you’ve done everything correctly.

The easiest thing is probably to post the .blend file somewhere where others can take a look at it. You can’t attach blend files here, you’ll have to post it on an external site, 4shared.com is a good free hosting site, there are many others.

Mike

The files are in:

www.nova-cs.com/blender/

Their names are:

colonia1.blend
colonia1.blend1
layout3Plane.zip

The ZIP file contains a .tga drawing I used for the UV painting. Please let me know if another file is required.

The landscape you will see in an space colony. It is a cilinder that rotates and simulate gravitational force. It has mountains, rives, lakes, etc. At this point iti is just a test. I am learning 3D animation tools and my plan is to do a movie (I am screenwriter too).

Thanks.

I didn’t try rendering it yet, but I see that the geometry is fairly large (around ~30 blender units). Try increasing the Camera Clipping End value to something like 500 or 1000 … I usually just set it to the max of 5,000. The default clipping of 100 might be causing the problem.

Hmm, strange, I’m getting the same thing, i.e. no camera loc/rot rendering, (I increased the clipping, it had no effect), I’ll try adding another camera and see what happens, unless there’s something unusual in the file (and so far it appears to be something different :slight_smile: ), there should be no big deal about animating a camera move.

Mike

You’re doing strange things with your camera …

Your camera isn’t your camera. Select the camera and press Ctrl-Numpad-0. Render again.

Two tips:

  1. Your subdivision level is quite high for such a structure. A level of 1 will probably be sufficient. Instead turn on “Auto Smooth” and use “Set Smooth”.
  2. You should definitely use a pathanimation for the camera. It’s a lot easier to handle and to correct.

Somehow you have 2 “users” showing for your Camera.001. Possibly you clicked on the ‘F’(ake) user and changed it to 2. I’m not really sure what changing that does … other than not make the animation render :slight_smile:

I found the easiest way to fix it was to delete the original camera, add a new one, then select the “todo.002” IPO for the new camera (When you delete cameras … or other objects for that matter, “their” IPO’s are not deleted … and the IPO’s are not really “owned” by an object … any object can use them).

Nice tunnel / texturing / lighting setup !, though as S.G. said, Subsurf-3 is probably overkill … also turning off SubSurf during “interactive display” (middle button will make the anim play much faster.

Mike

I did some of the suggested changes. The render is working now. I will do other imporvements as you suggested.

Thank you very much.