Rendering Hair Particle System

So i’m super excited with my progress but yet again I hit another wall!!.

For some reason I can’t render right version of my hair. can anyone help?

Left is the version I modelled and want! , right is what keeps rendering…
I created a particleSystem, then created a material(HairParticleSystem), changed the material in the renderSetting of the particleSystem to that HairParticleSystem, I’m also using the PrincipleHairBSDF in the shaderNode with the correct material attached!.. though the HairBSDF won’t change my hair colour… I’m Confused.

I’m completely stumped.

Show a screenshot of your modifier stack. It’s probably the subsurf, change render level to 1.

I only have the one modifier for the hair.

Add new material to hair emitter and put in on top. Top material will be used for hair, bottom for skin:

In the hair settings, you want to look at the steps for render and view, It looks like you’ve forgotten to up the render steps to match viewport.

No difference :sob:

Attach blend file, it will be easier to look into it

Is your problem the material or how it looks?
I agree with @Magnavis i think it’s the steps, crazily enough the preview and render steps are in completely different places. You need to increase render steps to match preview, probably to 5 or 6

I understand now, to fix this problem you have to remove all the material and add it again

New user can’t attach files… :sob: , email I’ll send to you though.

Render steps?

:pray: :pray: :pray: Blend file.

My problem is that it is not rendering how it looks in the layout window!

First of all, texture for hair should be on top:

Your viewport renders hair with 7 steps, so you should do the same with rendered view:

1 Like

You. Are. A Genius… :raised_hands: thanks a million!