Rendering issue: white object becomes flat and featureless

Hi all,

I have this white object, which I can’t get to render nicely. It becomes completely featureless, no way to see what it really is or should be as there are no shades or anything. Very unrealistic.

The object has a white colour texture; in object mode it has some shading which makes it look as it should be. See attached images: the render result, and a screenshot showing the object in Object Mode plus the Nodes that make up its texture.

Any suggestions on how to improve this?

Wouter.


Attachments


Are you sure there isn’t a second material accidentally assigned to these objects?
It looks as if those meshes have an emissive material on them, which would not only explain the “shadeless” look but also the fact that they seem to illuminate the objects around them…

This could to be the case indeed (I had some more very odd renders where light appeared seemingly out of nowhere) but besides that I wouldn’t know how this ever happened, I don’t see it in the settings. The screen shot that I attached before is the material that is used for this white object, I don’t see anything else linked to it, and this is a Diffuse BSDF materail, no emitter. The only material listed when I select the object is this “Plastic surface”.

Any suggestions on where to look for such a second material, or how to otherwise fix this issue?

Any chance you can upload a stripped down version of file (just the vases) somewhere so we can have a look?

Stripped down the file is just over 31 MB, which is apparently too big to just attach. I’ll see what I can do about that.

As possible solution to the problem I tried to re-import the object (it’s a FreeCAD created object, which I exported as .stl file). Without adding any material or so, it immediately became an emission like before.

Interstingly, when using a fresh file (new Blender file), it imports fine and doesn’t start to shine.

Just that object is 31 MB?!
BTW, when looking at your render I noticed that most objects (e. g. faucet and sink) have that “edgy”, flat shaded look. Is that intentional? Or did you not enable smooth shading on those?

That sink I imported from a file I found online; haven’t done much about it. Indeed it’s supposed to be smoothed.

A fresh file with just that one object imported is 17.5 MB (it’s got heaps of vertexes - the .stl is 13.8 MB, the FreeCAD original file is 4.1 MB). The stripped down file is 31.5 MB. So there’s some 14 MB of data that Blender has added that I can’t get rid of.

I’m having some minor issues getting it on a downloadable place; will have that fixed in 10-15 mins.
\

Stripped down file (31.5 MB) may be downloaded here: http://hikingtours.hk/pub/emission.blend

I’m using Blender 2.75RC1, by the way.

It’s not that difficult.

Select part of the mesh in question, ctrl+i to invert selection and delete. Delete other mesh type objects if they’re not necessary. Pack image textures that belong to the object in question, file -> save as, enable compress, name and save. Make sure the problem still remains within the new prepared file and upload.

Edit: file link posted just before this post.

Compress wasn’t enabled (shrinks it down to 10MB without modifying anything else), there are no materials on the object but what makes it white in that file is ambient occlusion with small distance.

Exactly: Full power AO with very small distance setting.


And holy smoke: What a horrible mesh…:wink:

Wow… Such a simple thing. That must have appeared accidentally. Thanks all for the help!

The mesh may be horrible but I’m not going to mess with it: it ain’t broke so I’m not going to fix it. It’s just what I got after importing the .stl file. I have better things to do, like finishing up the image so tomorrow I can print out the leaflets this image has to be in :slight_smile: Finally that work continues :slight_smile:

Which is debatable…:wink:


But I hear you: Since it is not the star of the shot, you might get away with one or the other shading glitch.

Actually this object is what it’s all about.

It’s good enough like this - it’s not shown zoomed in that much, final image is maybe 6-8 cm high and these vases are about 3-4 cm in that, if not smaller. You really can’t see these minor irregularities unless zooming in as drastically as you do. Fixing that is probably going to take hours of tedious work.

When I have the actual product made, I will probably use a real camera and real lighting to make a real photo of it instead :slight_smile:

A possible fix for the issues you show is to have the normals corrected. I forgot how that was done, a modifier iirc, I found that somewhere in a tutorial. Made a big difference when zoomed in.