Rendering issue?

Some times when rendering your final images have marks on them that you normaly dont want.

Example: there is random filled in areas that have little black dots on them

anyway to fix this?

I can’t see your screenshot unfortunately (the page shows loads of ads, but no image…), but it sounds like you have overlapping faces, i.e. two faces in the same spot. So check your geometry. Or, if you’re using Cycles for rendering, you will have to increase samples to reduce the noise (in the Properties panel, Render section, under “Integrator”. It’s set to 10 by default, which is pretty low)

I was using the text feature in blender and it make my text have marks on it I’ve tried recalculating normals and deleteing duplacates neither worked

image : and its not just this text its any text I do

here I figured out how to upload images

Well… it’s still hard to see. Can you post your .blend file? There’s an easy .blend-upload feature on

did that blender file help show anything?

I gave a look in edit mode, and there’s a problem with several of the letters :

What font were you using with Blender text function to obtain those mesh problems ?

I was useing the font ash, try it with this

is it even possible to use the blender text feature and not have overlapping surfaces?

When using the text function , type the text then in the Text panel :

  • at the Geometry tab, Modification - set Extrude to 0.3
  • at the Geometry tab, Bevel - set Depth to 0.035
  • at the Paragraph tab, Spacing - set character to 1.20 (so the letters don’t overlap with each other with the bevel)

Then convert to a Mesh , assign the light green material to the letters, then select the top and the bottom faces of those letters and assign them to the deeper green material.

This way, you have nothing overlapping faces

edit : that’s probably what you did from what i see.
The problem if you need flat surfaces , after separating the top and main body, to fill the main body of each letters i’m afraid you’re going to need to do it manually, the filling code seems to fail horribly for some of the letters, leading into the problem you’re experiencing up there.
Lot of the problem may have to do with the beveling that did made some face crossing each other, puzzling even more the face filling code.

now how do I do the colors? do I have to select each Face/ Vertex?

After conversion to Mesh.

-Add a Material to the whole text with the color you want, like you did in the video
-Add a 2nd material, like in the video, with the color you want to use for the top and bottom of the text.
-Go to edit mode then select the top and bottom faces while letting the main part of the letter unselected

Then in the Material panel, select the 2nd material, and click on the Assign button, so the selected faces will be assigned to that 2nd material

how do i select it like you did? this always happens to me it only selects the front

I see.

  • press Numpad 5 (or View -> View Persp/Ortho) to get into Orthographic view , in your video you’re in Perspective view, it’s not helping when selecting.

  • Now press this button to disable the “Limit Selection to Visible” that is the main reason you can’t select fully the faces on the top :

  • Press B and retry to select like you do in the video, with Ortho view and “Limit selection to visible” disabled, this time it should work.

Thanks that worked, now what do I do if I follow your steps and still get the overlapping faces?

If you do those steps, you should not have overlapping faces.
I tried with the “Ash” font you mentionned and i see no such thing.

thanks so much

oh, what do i do if it happens on somthing other than text?