Rendering only changes in animation

I have a scene that I need to render, about 40 seconds long. It took about 16 hours to render. (I need to render this again at different angles) However, very little changes in my scene, except for a few animated textures. Is there a way that I can tell Blender to only re-render what changes in the scene? I was starting to wonder if this is where baking comes into play, but I’m not very familiar with that. If anyone could point me in the right direction, it would be much appreciated!

could you be more specific as to what you changed in the scene?

I guess I should rephrase. I haven’t changed anything in the scene. I’ve included a frame to explain better. There’s a lot in this scene that doesn’t change from one frame to the next: The wall, the control surface, the shadows, the tv enclosures. The only part of the image that changes over the course of the 40 second animation is the content of the monitors and the color of the lights.

The render is extremely slow. I don’t need Blender to re-render the shadows, the control surface, the walls, etc. for every frame since they don’t change. Does that make more sense?

yes. you can do that. you have two options. you can do it in the video sequence editor, or, you can do it in the composite node editor.
in the video sequence editor:
render a frame of the background
move everything but the screens to a hidden layer ( you may have to also duplicate the monitor encasements, and give them an occlude material, and leave them on the same layer as the screens as well )
set your background to be transparent, and render your animation of the screens in file format .png
go to the sequence editor and use shift A to append your background image, and drag the right handle to the appropriate frame.
now append your image sequence of the screens, and with both strips selected, add an alpha over cross.
additionally you can save a lot of render time by turning off ray tracing, and other unnecessary settings when rendering your screens.

for the composite node editor, here is an explanation of the node setup:

Modron’s absolutely right, this is essentially a compositing issue.

Another couple things that would help us to help you: do the lights actually illuminate anything in the scene, or just change color? Also I’m assuming you’re using the Blender internal renderer rather than Cycles.

Thanks for the advice! I’ll try that out today. Yes, this is using the internal renderer (haven’t gotten around to figuring out cycles yet). And the lights just change color.