Rendering Problem - Can't Render Mesh Object but can render background

Hello me again!

I’ve made a mesh object which is converted from a metaball object. I am able to color my object and edit it, etc. Initally I was able to render it through F12, but somehow after some time, I couldn’t. It only gave me a blank rendering screen, and I couldn’t see my object.

I’ve then added a background under world, and I can render the background but not see my object.

I’ve searched the internet for solutions, and alot of them don’t apply except for one that I don’t understand - It said there’s a button in the Outliners or something that I could have mistakenly pressed on? I couldn’t find anything like that - they say it was a button that lets you turn render on or off for certain items…

Please help! :smiley:

thanks!

There are some options:

1.In the outliner it is the third icon (RenderwindowIcon) behind the name of your object.
There you can toggle render on/off.

  1. Another idea: you could try, if you accidently set another object as your active camera.
    Pressing 0 on the Numpad gives you the cameraview in the Viewport.
    To set the camera back to active. select the camera and press Ctrl+0(Numpad).

  2. Perhaps you accidently deactivated the renderlayer for your object in the renderlayersPanel.

  3. Check the scale of your camera in the TransformPropertiesPanel.(Press N)
    This should be 1 on each axis.
    If one scale is 0 you won’t render your object and you won’t see anything through your camera by pressing Numpad 0

Patel

So… I clicked on the window type button and went to outliner… but what Renderwindowicon? And whats behind my object?

  1. Perhaps you accidently deactivated the renderlayer for your object in the renderlayersPanel.

Wheres this renderlayers Panel?

Here’s some screenshots

http://i538.photobucket.com/albums/ff349/Finar91/SceneRenderLayers.jpg

http://i538.photobucket.com/albums/ff349/Finar91/RenderWindow.jpg

Thanks

id try just making a new file and appending your stuff over, just a thought

I marked the Icon and the Renderlayer on your screenshots.
But I can see the RenderIcon is active and the renderlayers as well.

It seems, these are not the reason for your problem.

You could try to go the way Brados33 suggested (Maybe the shortest way),
and you could try to add a new camera, select it and press Ctrl+Num0 to make it active.
(Youcan use the menu as well: -View- -Cameras- -Set active object as active Camera-).

Point this new Camera to your object and try to render.

If you still have the problem and If your file is not to big, you could post it here and we could look into.

Patel

Attachments



How do I append my data over? That seems the best idea to do =(

To append data:
http://wiki.blender.org/index.php/Doc:Manual/Data_System/Linked_Libraries

Did you try to create a new camera?
If there are some settings in your camera not correct(for example the scale or the clipping), it won’t help to append it into a new file.

Patel

Woot! Thanks for the help, I now can render both the object AND the background!! And thanks for telling me about appending, it will definitely help me alot in the future!

Joyce

Woot!! Thanks SO much, it worked! I can now render the object as well as the background. And thanks for telling me about the appending, it will defnitely help me alot in the near future.

Joyce