Rendering problems :(

I have finished an animation that features a tunnel, and a traintrack.

In the blender screen, it looks like this:

However when I render it or put it in an animation it looks like this:

For some reason the tunnel and track has been removed.

Everything is in 1 layer.

Does anyone know why it does this?

I might be Wrong, but maybe FLIP NORMALS ?? or uncheck Dubleside??
It’s realy wierd thing… :x

what do you mean, removed? blender doesn’t remove objects unless you tell it to do so. what could have happened is that your objects are being moved. why? this happens if more then one objects share the same IPO (curve data, hodling information about position, rotation and stuff). so if some of your objects appear in a different position after a render, select each of then and press “U”>> Object and Obdata. then reposition them and rerender.

it can’t be the normals, blender always renders objects (even if they are flipped)…

hope that helps


Okay, I did the U button check thing.

Then rendered it.

And still the same problem.

If anyone knows a lot about this sort of thing, could you please check it out:


file is corrupt->can’t open

Try this:

Converting the tunnel to a mesh did nothing, and attempting to convert the rails to a mesh crashed Blender for me (on Windows XP).

Still trying.

Oh, I figured it out.

You’re using dupliverts to create the wooden supports and the ties… dupliverts that stem from the rail and the tunnel. That is your problem. The emitter never shows up.

For a quick fix that will keep you from having to change anything, simply duplicate the rail and the tunnel (shift+d) and then uncheck the dupliverts button on each.


It worked!

Thanks to you I have finished my very first Blender animation.

I’m so happy. :smiley: %|

I never would have guessed to, Duplicate them.

Thanks, for going to the trouble of figuring it out.

:smiley: :smiley: :smiley: