Rendering problems

So I have had blender about a week now, and I’ve encountered a couple of problems with some things in my most recent project.

One problem is that one item (the body) isn’t appearing in the render but is in object/edit mode etc, and the camera icon is highlighted, which was the only solution I’ve found, yet that’s not the case.
This is the only object with a particle system attached to it so I thought that may affect something, although the particles of hair are showing up in the render.

The second problem is that the glass in the goggles is rendering really grainy and poor quality, regardless of the sample size increasing.

For the body, in its Particle System menu under the Render tab, is Emitter unchecked? If so, check it. No clue about the glasses, though.

Yep emitter is checked

You really need to supply a link to your blend file. How is anyone expected to know precisely what is wrong with your particular scene without actually seeing it ? You will get an answer quicker and much more importantly you won’t be needlessly wasting other peoples time as they try and help you

You can attach a blend file to your post or one of the many file hosting options or upload to and reply with the download link.

I’m really sorry, I came on here for help, I didn’t really know how it works…
I have attached said file


Minion.blend (1.2 MB)

  1. Emitter wasn’t checked in the Particle System tab.
  2. In the Outliner in the top-right, you turned off rendering for the Body object. You can enable it by clicking the little camera next to it.
  3. You didn’t assign anything in your Body object to the yellow material, so you might want to do that.