Rendering reflections from the wall on the floor

Hi All,

I’ve been reading posts here for quite a while as I’ve dipped in and out of Blender and I’ve finally put aside time to properly get using it and am really loving it. I’ve hit across a little problem I can’t seem to work out.

I have a wall which is reflecting an object and the floor is also reflective. The “initial” reflection works fine but the reflection from the wall is not showing on the floor. The image is below.

I’ve tried setting the trashadow property for both the wall & the floor and also bumped up the number of ray trace levels from 2 to 4 but it didn’t seem to do much apart from increase the render time :slight_smile:

I’m sure I’m missing something simple but I keep getting tutorials where its just 1 of the walls & floors being reflective and not both. Grateful for any help,


Tried lux / indigo? :slight_smile:

Material, Mirror Transparency, Ray Mirror, change ‘Depth’ to 3 or 4…

Hmmm… nope. Can’t reproduce it.

Can you post a blend?

Maybe this is what you’ve said you’ve already tried (you didn’t give the exact name), but normally that problem is solved by raising the ‘Depth’ parameter under ‘Ray Mirror’. Make sure it’s not under ‘Ray Transp’ or another property that looks reasonable like ‘Samples’ for example.

Again, sorry if you’ve already tried that. If that doesn’t do it, maybe post a screen cap of your material settings or a blend file?

Thanks for your suggestions guys, I’ve made sure that the depth (thats what I mistakenly called the ray trace levels earlier) is over 2 and that ray mirror & not ray transp is set for both the wall & floor.

I’m not sure if this is maybe something that needs environment mapping? I’ve not read too much about that but can remember the blender book saying it was for doing realistic reflections etc but seemed pretty complex to set up so I was hoping there’s an easier way with just basic materials etc. That book is several years old though.

I’ve attached the blend file. The floor & wall have their materials named.

Cheers again,


room.blend (247 KB)

I turned up the RayMir value on your floor to .52 or so… the missing reflection starts to become visible. My guess is that the reflection-of-the-reflection RGBs for the UDOX letters falls below some threshold when your mirror factors are set lower.

EDIT: I took your original image (from above) and used Photoshop to drastically increase the contrast. As you can see, the reflection we all thought was missing is actually there, but it is quite faint. My guess is that the 0.25 mirror on the wall multiplied by the 0.21 mirror on the floor means you have an effective reflection of 0.0525.


Beefcalf, thank you so much for that! :slight_smile: And that explanation of what is probably going on makes a lot of sense, I will play about some with the settings and see what happens now I’ve a better idea of what to change.

Cheers again!


Glad I could help… :slight_smile: