Rendering - strips in shadows - what do I model wrong?

Hi,

I created a simple bowl (see setup picture), set smooth and added subdivision levels. I made test renders, unfortunately I see two set of artifacts even if I keep raising the subdivision level. The render is the internal Blender renderer, with default settings.

The artifacts are marked. The red one is the one I can’t get rid of (stripes in that direction, on the right of it), and am interested in removing it, although the blue one is interesting too (I would expect a circular reflection, yet it has a kind of irregular shape, possibly because of the geometry…)

Do you guys have any idea of what is the error? (It is not the JPEG itself, I tested it with TIFF, same result.)

Thanks,

Tibor

Attachments




probably the shadow from the key light. If you don’t want so dark a shadow, add a lamp inside the bowl.

What colour depth do you have on your monitor? I can’t even see the stripes you are describing at 32bpp, but I imagine that its simply a result of the fact you have a smooth gradient there, and only 65536 (that’s 2^16) colours avaliable to your screen. Even at 32 bit colour you’re going to notice banding if you zoom in real close. Fraid theres nothing you can do about it, unless you want to buy a graphics card that does 48 bit colour.

PapaSmurf: no, not that one, that’s okay, maybe you do not see the artifact. It is pretty subtle next to the hard shadow edge, but I see it immediately… (you have to see the full resolution image to see it)

ben: Its on 32 bpp (and it is a ViewSonic VX924). But maybe my display is broken… I will check this image on another monitor.

Thanks for your comments!

Tibor

I notice those banded artifacts from time to time, but they usually go away when I have more than one lamp in my lighting set up. Try putting in a fill light (hemi – or other set to no shadows) pointing at the shadow area.

I can see there 2 different things. Don’t know, if this is what you mean?

The blue arrow shows pinches, created by subdivision.
Subsurf produces quads only (what is usually a good thing), but is this way not able to give a perfect spherical shape, because of those vertices, where only 3 edges are connected.
To get rid of this try using a higher resolution UVSphere by default and avoid the subdivision. Then you will have just one pinch in the center.
Or use Nurbs.

The red arrow shows banding artefacts, you can avoid by using dither in your render
(On the outputPanel)

Pat

Orinoco: thanks for the advice, I will probably use it, this time though I am trying out smaller parts of Blender and look for potential troubles.

Patel: great advice, I will change my geometry. Also, thanks for the name (“banding artifact”), at least I have something to look up on Google ;-). Dither is not available for single “Lamp”-s, I tried to increase the sample count (from 1 to 16), still same banding artifacts. I changed the light type to Area, there is no Dither in Adaptive QMC… I did a test render (see attached, the brighter one), it still has these bands. I will try some tweaking.

By the way, I attach the single Lamp and the Area light .blend files, if someone wants to play around ;-).

And a quick note: I found this great site, maybe you guys are interested in it: http://www.cgsutra.com/blender_tutorials/b0010_lighting_in_blender/lighting_in_blender.php

Tibor

Attachments


Actually, I would like attach my .blend files. Unfortunately they are 10 MByte each, and cannot upload them. Any way to make them smaller to fit in the upload size limit? I tried packing, but still 3 Megs…)
Tibor

Can you post the original blend file?

Patel: I actually did not understand what you referred to. I found the dither setting on the Output tab. Set to maximum, but there is no change in the final render. (See attached image in full size.)

Tibor

Attachments


Here are the files: http://cid-eda5cd6f0d162b4c.skydrive.live.com/browse.aspx/Public/BlenderArtist.org/Banding%20artifacts

I had a look at your files and in the bowl_lamp one, you’re using yafray as renderer.
The Dither setting just works for the BlenderInternal as far as I know.
I assume you would like to use yafray for GI.
So once activating GI your render will look totally different anyway.

BTW, you won’t need such high polycount.

Pat

High TFuto,
I didn’t download your blend file, but I think you should check you clip distances of your lamps.

Actually, that is just a wrong setting, I do not have Yafray installed. I used BlenderInternal. Let me fix that file and re-upload. (A friend of mine touched the setting just before I uploaded that file…)

I increased the MultiRes setting so high because I thought that was the reason behind this bands appearing.

Tibor

Hi toontje, please help, what makes you think of that is related to my issue?

Tibor

If you look in shaded mode the artifacts will be present - no rendering needed. I think this is realted to the density of the mesh and normals interferencing.
Below is Yafray render test. As you can see the artifacts are still present.
No I was wrong - it is probably connected with the display quality. I can see the same artifacts on a simple cube.

Attachments


Yes, I tried to set MultiRes on level 1, and the artifact is still there, both in shaded mode and in rendering.

(Actually your Yafray rendering is showing even more artifacts than the default renderer version.)

Now this is indeed funny to have too separate renderer show the same problem. :slight_smile:

“Tibor’s ultimate challenge begins! Apply now! Who can render a simple cube without artifacts?” :-)) Anyway, this seems to be a rendering problem then.

Tibor

(Here is the lowres setup: http://cid-eda5cd6f0d162b4c.skydrive.live.com/self.aspx/Public/BlenderArtist.org/Banding%20artifacts/Bowl|_Lamp|_Lowres.blend)

Attachments


And the solution is: well, the secret is in the monitor controller chipset. Download the gradient attached, open and scale to 100%, and try changing the contrast on your monitor (mine is TFT), and you will probably see the stripes moving and their number changing.

It seems that the Flash DAC makes some errors at certain values

Oh my god…:eek: :no:

Tibor

Attachments


Well the problem was located and the solution found :smiley:
Good job!

Yeah, big relief <sigh!>. The last thing I didn’t know about 3D modeling (khmmm…) :wink:

Tibor