Rendering texture in 3D view

Hi everyone,

I am learning how to use blender and I’ve fallen in love with the program. The learning curve is still steep though, therefore, I would appreciate some help regarding texturing.

I am able to see materials and textures and their modification on the preview window, but textures do not render on 3D view despite activating textured object and GLSL. I’ve tried all available controls without success. I also observed that rendering shows textures at times, but whenever I animate something the texturing features are lost.

Any suggestions on how to approach this problem?

I am running Blender 2.57b on a quad PC under Win7, the graphics card is NVIDIA

“Viewport shading” is the place you must find. its next of “object / edit mode” menu. Or you can press “N” and find from that menu “display” and “textured solid” checkbox.

Thank you Arman!

I have tried that option several times to no avail. Any other suggestion?

best regards,

Ensure you have added the texture in the to the objects material and mapped it to the colour channel. If you are using UV maps, set the texture mapping to UV. The texture won’t render it it is not linked to the objects material.

Thank you Richard,

I had some success rendering, although I can see a huge difference between OpenGL render and rendering through the little camera on the properties panel. The second is closer to the preview window. I can see the modifications on the preview window but not on 3D view. On 3D view the color change is indicated but not the reflections from mirroring. I do not see an obvious place where to link the texture to the material. I chose the object for the mapping coordinates. I am not using UVs. How do I make sure that the texture is linked to the material and that both are applied to the object so that they can be seen upon rendering and on 3D view?

Thank you!


Rendering works now, but the textures can’t be seen on 3D view.