Rendering this scene grows my RAM and hangs the system

I’m using GNU/Linux and Blender 2.67. My desktop computer has an nVidia video card with 1GB of memory and my system has 4GB of RAM. I downloaded the following scene:

And when I render immediately grows RAM and system becomes slow until quickly become unusable.
The blend was added in 07, 2012 as you can see. So I wonder if the problem occurs because there is an incompatibility in that scene with the current version of Blender, or is because my system has small amount of memory.
Are there any settings I can change in Blender to this does not happen?
I’ve tried with memory settings on User Preferences > System but seems to have no effect.
Thank you.

You could try half particle counts on grass, stones and other to see if the memory limitation is the reason behind this.

Thanks for your answer.
I’ve dropped down to 1/5 the value in each element, and the problem still occurs.
I’ve done a quick installation of Windows XP and with this scene Blender 2.67 closes at 5 seconds into the render. Windows Terminal reports this in the last line and I don’t know if it’s something that might be useful:

Calloc returns null: len=33554468 in eh buckets, total 1292966092

I installed Windows 7 on the same machine, same problem.
Sorry for my insistence, but I wonder if anyone can render that scene in Blender 2.67
Thank you very much.

I am not a member of that club for several reasons, so i can not help - have no access to file.
What i could suggest besides whats done already is dropping all particle systems rendering in file by unchecking camera icons in Outliner window, then adding them one by one. Another way of debugging so to say.
I you want you can test this file - 20000 level 2 subsurfed monkey head pile. It has 2.8 Mio faces during render and uses here around 760 Mb of RAM. Despite it consisting just one plane and monkey as a real mesh it’s size is around 6Mb.

YAFU, I can render this file and it use 4.6 GB RAM!
Particles are not the problem but something strange with materials.
I don´t have a closer look but try to switch off all materials from the ground, it need only 300 MB then.

Cheers, mib.

Yes it renders on 2.67.1 - but RAM usage was 7.15 GB at peak - CPU rendering. Reducing the particle system for grass and rocks to 100 each didn’t help really. RAM usage is 6.15 GB. Strange that your RAM size differs that much, mib2berlin.

After loading the scene and before rendering RAM usage is roughly 3.4 GB. System, Blender some Firefox instances. How much RAM is used on your system, before you press render, YAFU?

minoribus, i switch off Children for grass and reduce particles too.
I use Blender internal, was default setting on original file.
Specs in my signature, cheers.

1500 posts \o/

@eppo, I can make that render you shared with no problem, RAM usage is small. I also had able to render other complex scenes, so I was surprised that this desert scene consume much RAM. I do not know if that scene’s license allows me to redistribute the file to share here. Do you know if I can do that?

@mib2berlin, minoribus, Oh! that’s a lot of RAM. In GNU/Linux my system takes 700MB of RAM before start the render. Then I will do more testing with that scene, but I first wanted to know if anyone could do the render successfully. So knowing that the scene needs much RAM, I think I can give me an idea what the problem on my machine. Excessive use of Swap on Linux (you know the problems when that happens on Linux), and perhaps in Windows as it uses a lot of RAM from the beginning, I also have fallen short in the paging file.
Now, I wonder if that’s excessive RAM usage is normal for this kinds of scenes or is there something wrong with that scene.

Thank you very much to all.

Well, I have read the license and apparently it can be redistributed(I hope I have understood correctly, English is not my language):
Downloaded from:

YAFU, there is a subsurf on the ground although it is a very dense mesh.
Saw not much difference in render result deleting it.
I think it is possible to high optimize this scene.

CC 0 meant you can do what you want with the file.
EDIT: I use 2.68 RC

I did some experimenting on 32 bit XP PC with 2 gigs of RAM and crappy ‘Intel Inside’ video. Sure, not modified file was crashing blender almost in an instant.
Particle groups switched off did not give any better result, so that was ground plane which was killing the joy.
First i added some ‘cornerstone’ cubes to see what’s covered by camera, what’s left out. Mesh was subdivided a lot, so i had to apply Decimate several times to get it more lightweight. Then with a plane shaped like camera coverage and Knife Project deleted unused parts of the ground mesh.
Switched back on all particle systems and while it says it has 33 million faces during render, memory consumption is around 1/2 Gb and it renders ok.

Thank you all for taking your time to do that testing.
@eppo, I’ll read about those things you say (I’m new to blender) and I’ll try making that scene uses less RAM.