Rendering to mov washed out

Hi Guys,

I’ve been trying to render an animation to .mov (h.264) and it seems the colors are all washed out compared to a 8 bit png sequence for example (file sizes are super small as well). Any ideas what I need to set to get a result close to lossless? (I tried various settings, bitrate, compression, nothing seemed to help that much)

Tried googling for some time, not much luck.



Mov files can have playback gamma issues in some players, it is probably not a data, but interpretation problem. Load the filr in Blender and see if it differs there. If it doesn’t, it is not video itself but metadata and/or interpretation error.

Washed out .mov videos are a thing from way way back. I’m surprised you haven’t found anything on this.

So put it in very simple explanation: It all goes back to the time when Apple computers used a different gamma value compared to PC’s and Unix computers.
Nowadays everything is more or less ‘standardized’ to a gamma of 2.2 with some small variation in curve color tweaking depending on monitor source, e.g. PC or TV.

Its often better to render in frames, and do the conversion to a mov later. It also help with render crashes, as you can just restart the render and keep on getting frames, instead of a broken .mov video.


Thanks for the suggestions guys!

kesonmis - I don’t think it’s player related, both dji and nuke should display the right colorspace.

RobWu - Sorry, I wasn’t specific enough - I’m familiar with the linear workflow, and I know there’s a lot of information on it online. What I haven’t found is relevant information on rendering .mov-s in blender. I’m rendering to an image sequence and trying to stitch them together in the compositor, that’s when the data loss occurs. (I’m fairly sure it’s data loss. Despite me setting the quality to lossless and upping the bitrate the file sizes are just way too small compared to using the same encoding in nuke, where the output of the same sequence looks fine)

What are you doing in Nuke exactly? What colorspace do you set in Read node? Never trust the setting it defaults to, set input colorspace manually. For example, for some prores variants it defaults to gamma 1.8, which is obviously very wrong.

Compression data loss will not cause gamma shift, so problem is something else. Did you try loading the mov in Blender to see if it matches?

I’m just using nuke to convert the image sequence to mov. Nothing fancy, read, write, that’s it. (that’s the main reason I’d like to use blender for this, but I’m not really familiar with the compositor. just recently switched to blender). I’m using raw inputs in nuke.
You’re right, looks like a gamma shift. What I couldn’t figure out why the gamma would be different if I set mov as an output compared to 8bit pngs. I’d normally use exr but these are just some turntables for models.
I didn’t try to load the mov into blender, but tried nuke, dji and rv. Since the client is using mostly rv for qc-ing it’d need to display fine there.