Rendering too slow; particle mode

Hi there, it’s me again with my girl.
I have couple of quiestions. First, I somehow made my file so big, that rendering takes now several minutes. I can’t even attach it here, it’s about 4Mb now. Is there way to change that?
Second, when I’m in particle mode and trying to manage hair it appears seethrough, so if I’m combingher bangs, hair on back of her head is moving too. Is there something I need to check/uncheck?

To hide the hairs you shouldn’t see (and so affect only the ones you see when you’re combing) , enable this in the Particle mode :

For the rendering slow, particles are always slowing down my renders a lot too, so i’m not sure if there’s anything to do to improve without having to lower a lot the amount of particles rendered

Thank you!