Rendering turned to fragments?

Whenever I try to render my model, while the first two objects turn out okay, the rest turn into fragments in this:

How do I fix this?

I put it like that size and quality because rendering it full sized would take up hours. Hopefully you get the idea. Oh, and feel free to give me some C&C.

PS: Whatever happened to Blender’s IRC channels?

Check in the outliner how many objects you have or check all the fragmented meshes in Edit mode with W-7 (remove doubles), because superimposed copies of objects does that.


Where can I see the outliner? And is it a problem if I have a lot of meshes? Some of them aren’t even meshes; each “machine” is a collection of both meshes and surface objects. And I don’t think surface objects leave doubles… It seems that no matter what it is it gets more fragmented as it gets farther from the camera. And each objects aren’t right on top of each other…I made one machine, then duplicated it into many, editing each slightly on the legs.

Okay I’m not the greatest help but it’s W-5 to remove doubles. I think i’ll go and hide now

Yes, sorry. I’m using a CVS build so W-5.

Outliner is in the Menu of different windows like IPO and Action etc. If it’s set to OOPS change it in that window’s View menu. Meshes or Curves, don’t really matter, it’s called Z-Fighting. The camera can’t decide which face of which copy to render because they are so close to one another on the Z buffer.


You first button is probably in 3D in the Windows type. Click it and you find all the other types UV, text, etc. Find Outliner and click. You have the option to switch from View > to Outliner or Oops. All your data is graphically represented here, but you can’t change much here. It’s just a graph…

My outliner shows me a about five hundred boxes with abbreviations of object types, and a lot of hair (nothing else to describe all the lines) connecting each of them.

I’ve never encountered Z-Fighting before…but even when I resized everything by x2 it’s still the same. So how do I fix this?

If you have that much hair showing you’re in OOPS mode for that window. Go to the header and click View >> Show Outliner. Then hit Numpad + until everything is visible.

You should have a graphic directory of every object in that scene. If you have named your machines you will be able to see exactly how many there are (let’s say 20). Any more than 20 you have duplicates occupying the same space so delete them.

If that doesn’t work send the .blend to me at ([email protected])


The terrain (Plane.024) has Z-Invert on in Materials. Guess what that does?

I spent a lot of tedious time on this blend, you yourself know how long it takes to render, so I hope you’ll take the time to read this and improve some of what you have.

Name your Objects. You can do it with Ctrl-LMB in the Outliner or in the Datablock in F9, Link and Materials.

Use layers. Main light and Camera on Layer 1, Backlight on Layer 2, Fill lights on layer 3. Terrain on Layer 11, Original bot on 12, copies on 13, something like that. If you do it this way then you only need to select 2 or 3 layers for test renders (quicker) and if you NEED the pic it’s so much easier to render layers 1,2,3 and 11 in one pass and 1,2,3,12 and 13 in a second pass and composite them together.

When experimenting use dummy blends. Open Dragiath.blend and save it immediately as DragiathDummy.blend. That way only the things (like material and texture settings) that actually work can be appended into the Dragiath file and if you get lost you can always compare.

Example; on the terrain mesh you are using a Blinn Spec shader (soil and rocks don’t have much if any specularity) which modifies the spec with refraction. Refraction happens in transparent substances and is only useful at close range (near the camera).
The same material is mapped to Translucency (goes well with Blinn’s refraction and spec but not with mountains) and the single texture is mapped as a Stencil (you need more than one texture for this texture to stencil the one before it). If you did these experiments in the Dummy.blend they wouldn’t make their way into the real.blend. And nor would Z-Invert, chuckle chuckle)

Use Raytracing only where the camera can see it. There are lots of the Machines parts that have raymirror set but are so small that (in this pic) all it’s doing is eating up render time and filesize.

Save complex objects in a seperate (master) file. Icounted and one of your machines has 37 mesh objects and 1 surface sphere in it. Better to save the original as it is in it’s own .blend and stick it on a CD. Then for a .blend like this you can append it in, change the surfacesphere to a mesh and join them all into one mesh, much easier to work with.

Otherwise there’s lots of nice work in that .blend.