Rendering without the blue tint on the back ground and Mesh

So l am trying to render my mesh with the turn table and it all looks well except for one problem: everything is blue and l have NO IDEA how to get rid of it! I’ve tried to see if there is any sign of blue chosen in colours and what not and there appears to be no sign anywhere!

Here is what it looks like, if you could all please help me out, l would greatly appreciate it! Cheers

Try doing this:
add a cube anywhere
goto materials tab and look through to find that color
type that color into the search for the outliner
find the object that owns the material and delete the material first, then the object

There must be a plane or a cube somewhere to cause that particular space to become blue

It’s probably the environmental light, you can either change the color of it to a plain white, add a sunlamp to add different coloration to counter the blue, or use a light path node to make the blue background only visible to the camera.

Check your world settings

Yup, it’s gonna be the World.