Renders come out "dotty"?

Whenever I render a picture in blender, it comes out very “dotty”. I render it with 1,000 samples, it’s dotty. Even with 10,000 it still has a few. I’m guessing I’m missing a setting or something? It looks like the image is made of noise, with more samples it gets a little less noisy but not much. Help is very appreciated!


<- Rendered with 10 samples, but more only helps a little bit.

EDIT: Also, I followed andrew price’s tutorial for this cave, and he rendered a few of his with 1000 samples and it looks 20x better.

Looks from here like you have fireflies from having your emission too high in some of your materials - no matter how many samples you set, too high of emission will cause fireflies and that won’t clean up. try to lower the emission range while observing the effect in the viewport.

Read about “Clamp setting” in render options.