Renders low quality, and blurry. Anything I can do?

Both are 100% 1080x1980.

There appear to be a lot of glossy materials, but you have given it nothing to reflect just a gray background, try lighting the scene with an environment map

I guess you are rendering with cycles… How many samples do you use at render ?
Did you have a try with the denoiser ?

++ Tricotou

+1 for adding an HDRI for lighting and reflections and +1 for using the denoiser. The first will make the biggest difference I suspect.

Yep! I was using 600 samples. But I consulted a classmate and he bumped it up to 2000 something so it might work better. Yep, I was using a denoiser. I have a gallery of settings here: https://imgur.com/gallery/sMm8SgM
Thanks

Can you show me where I have to go to change that?

That looks cool. I don’t really have time to try something new like that right now, but I’ll try it for later projects. Thanks

1 Go to the World Tab.
2 Click Use Nodes.
3 Click the wee button to the right of Color and choose Environment
4 Navigate to an HDRI image.

If you want to rotate the HDRI easily and you have the Node Wrangler addon activated you can go into the Shader Editor (or Node Editor in 2.79) select the World, select the HDRI image node and hit Ctrl+T. This will give you a node where you can rotate the environment in Z