Renders only black and gray

I saved my file a few days ago and opened it toaday and hit the render button to look at it and it was only black! Here is a pic

Here is how it is supposed to look

and here is the blend file

I HAVE LAMPS!!! plz dont say “maby you dont have any lamps”. I have done all i can thing of to fix the problem I tried adding about 50 lamps, reloading the texture, deleating and reading the camera but nothing will work. What is wrong??? :eek:

You have Use Object color selected in your UV face mapping. Go back into Edit mode, select all faces. Then hit cntl F for faces special and choose “Clear Flags”, then click “Object Color” followed by OK on the next popup menu

I tried that when i hit control + f nothing happens.

You are in EDIT mode, Right?

hmm. Make sure you also have the UV mapper window open just to make sure you activate UV map mode

I tried in object, edit, and UV face select but control+f does nothing.

We can’t really help you unless we get a little bit more info: First of what is it supposed to look like? As far as I can tell you have a tank with a black material assigned and no textures.
If you cannot provide the blend file you should at least show us what your material and texture settings are and maybe the setup of your scene as shown in the 3D View. Do a GL render (little picture icon in the header of the 3D View) to show us what is displayed in your 3D View or do a screenshot.

It should look like this
And here is the file , I could have sworn that i uploaded it…

It should look like this

And here is the blend file , I could have sworn that I had uploaded it though…

Here is how it is supposed to look

and here is the blend file

Also, what version of blender are you using? 2.46 or still 2.45?


Your file doesn’t contain the images you are trying to use as UV textures, so the tank is rendering black.

I am using Ver 2.45.

Have you moved either the .blend or the texture file? If so you will have to reset the file path to the texture.

I had moved the texture but i put it back and reset it and stil nothing.

This area…
…shows where blender expects to find a particular texture file. In my case, I’m using a movie instead of a still photo. After you have relocated your original textures there, you may have to hit the “reload” button to wake blender up to them.

For future, you may like to use the “pack” function (File menu >> External Data >> Pack into Blend) which embeds textures into the blend file itself.

EDIT: I’ve just had a download of your file. It’s the UV editor where your textures (steel01, metal.BMP, iron01.BMP and dull01.BMP) need to be loaded.

None of my objects have anything on that page except the preview and texture box.

No, no, don’t just hit reload, load it again from the start like it was a new image, or use the ‘fix broken links’ script.
…and can you upload a packed .blend?

Are you saying there is no image texture loaded ?

I’m having this same problem - I made a model yesterday and uv mapped it, rendered it and it worked fine. I then copied the model to a different folder and mapped it to a different image and it worked fine. I get up this morning and the new image only renders black.

Then I noticed this - if I open the new image it will render in black, then if I open the first image ( without shutting down Blender first ) it will also render in black. If I then shut down Blender and restart it the first image will render correctly again. Seems to be some kind of cache problem.

Anyway this is my first post, hi everybody and I look forward to chatting with all of you !

Thats what i ment i hit new image and selected it again.