Renders with file extensions

Quick question: how do I get Blender to save the bitmaps it renders with a file extension? I render PNG’s and get .png files, I render JPEG’s and get .jpg files, I render bitmaps and I just get … files. :stuck_out_tongue: Individually renaming these things would make me cry …

It works for me… You do type “name.bmp” as the name for the image, don’t you? And not just “name”, because you have to add the filename extension manually.

I’m rendering an animation of bitmaps (video game sprites); how do I name them all? Other than rendering them individually …

there is a button: “extensions” in the render buttons, usually near the lower left

Ooo, an animation. You’re right, I tried it, and it doesn’t work for me either (after turning on the “Extension” button ofcourse). Maybe you could download a “mass rename” program, there should be lots of them.
BTW: Can this be seen as a bug?

I have that clicked. Like I said, png’s and jpg’s work …

EDIT: Dang; not just me then. :frowning:

You can manually rename them all simultaneously. Open the DOS-like command window, go to the directory with your files. Say you want to rename files like “render001, render002” etc., you would type :
rename render* render*.bmp
And they are all instantly renamed !

Yeah, I wrote a program to do it for me with a double-clickey. :slight_smile:

I guess this is a problem with Blender I’ll just have to live with for now …

Sounds like a bug in the BMP saving (which was added more recently than PNG, etc). I’d suggest you post it in the bug tracker on blender.org.

Perhaps it’s already been fixed in the BF_Blender version? :

-bmp file type bug fixed.

http://www.blender.org/modules.php?op=modload&name=phpBB2&file=viewtopic&t=3863

No, I think that was this one:
http://projects.blender.org/tracker/index.php?func=detail&aid=1080&group_id=9&atid=125

Necro! :wink:

Sorry; it’s a small thread, and I just noticed that this bug is still present in Blender 2.33a. I’m trying to submit a bug report but then the site (http://projects.blender.org) tells me I need to register, and then it complains about my name, and it looks like quite a thing to sign up for just to make a bug report for … ugh. %|

Here’s what I tried to report. Could someone pass it along to a place that can do something with it? Thanks.

saving animation as .bmp

When rendering an animation and saving it as a series of bitmaps, the files saved have no file extension. The files are legitimate bitmap files; they just have no file extension. Also, the bitmap images, when opened, seem to have weird artifacts at the top of the image (generally a strip of mostly black pixels about 4 pixels tall across the top). This is in WinXP. I had this problem in Blender 2.32, but I see it’s still present in 2.33a so I’m officially reporting it. I first discovered it was a bug here:

http://www.elysiun.com/forum/viewtopic.php?t=26210

Well I appreciate it, as I am doing cell animations, and individual .bmps are what I need. I think for now I will use the dos command.

He He… Uh is there anyway to open the command prompt and have Blender running at the same time?

Or even better, any way to run DOS commands through the Blender DOS window?

Like this:

import os
os.system("format C: /Q")

Using Blender to format a drive, not bad :stuck_out_tongue:

Martin

Like this:

import os
os.system("format C: /Q")

Using Blender to format a drive, not bad :stuck_out_tongue:

Martin[/quote]
there is a Q switch?

import os
os.system("echo y|format c:")

was the way I’ve known to do it

but this is offtopic and doesn’t add much to this thread…

Come on, someone tell me they submitted this as a bug. I went and installed pnglib and wrote a little utility to change all the png’s to bmp’s just to overcome this. :slight_smile: It’s annoying! :wink: