Rendreding time going up

Hi :slight_smile:

 I have a scene that took 2min35 to render if i don't put the ground (i'ts a house with some three around). But with the same lightening, when i put a ground (the meshe has 8900 poly), the rendering time pass over 10 minutes... I've got a twice processor 2.4 ghz and one gig if ram... Because i'm doing a animation, i can't waiste that time...

 Why the ground make it become harder to render. I have remouve the shadow, the ground is a flat one. I even remouve the textures...

Anybody have a clue? Maybe it is the light inside the house that take time to calculate… If so, how do i tell the light not to pass throu wall, without having to activate the shadow (because shadow slow down even more…)?

Thanks :slight_smile:

Me again

 If i render the land and the three alone : 10 sec per frame.
 If i render the house and his lamp : 28 sec a frame...
 If i render bonth together : 10min 30 a frame????

 I have take the lamp inside the house and i have clic on "layer" and i have put all the house in that same layer, so the light will only affect that layer... But still, i't take 10min30 a frame?

Lots a patience it is required :o)…

Me :slight_smile:

 I'm going to sleep. Hope that someone will find a way :)

See ya later :slight_smile:

You certainly point to a possible solution strategy: render the two strips separately, then composite them together in the Sequence Editor. That is the technique that I use very extensively, on a system much, much slower than yours.

I do not know exactly what settings you may be using, and the difference in speed does seem rather extreme to me, but I do know that the increase in render-times is not linear.

In any case… the house and the ground don’t move from one frame to the next, so why continue to re-render them? Render them but once, and composite the same image into every single output frame. (If shadows and so-forth are cast upon the ground by moving objects, those shadows can be treated separately, through the magic of “shadow only” materials.) The various composite layers are stripped down so that they include only the minimal amount of material. If you are doing animation, I don’t think there’s any other way to get the job done.

Thanks for the advice

 I never use the video sequence editor before. The camera is moving around the house, so i guest that i have to use a "alpha" thing around the house... But still, i have some tree betwin the camera and the house, and some after the house... So i't seem to have tree layer... Or, i just can remouve some of the three betwin the camera and the house...

I’ll try that towmorro :slight_smile: Hope that i learn fast how to “re render” the video squence editor. I guest that is some kind of movie editing…

Again, sorry for my bad english :slight_smile: I’m from Montréal QUébec :slight_smile:

try adjust the octree value (try 512, I’d say, at first glance)… it should speed up a lot rendering… how? make a search on octree in these forums, it has been discussed many times :wink:
good luck with your rendering

For general purpose speed rendering increases: please also consider lowering the number of OSA (8 is a good mean value), lowering the number of AO samples (if you use it at all) and using non-ray lights when possible

Hope this will help

Hi olivS

 You're my savier :). The octree value make it come 10min30 to a minute... I was keepeing it at 64, thinking that the lower the number was, the faster it will be... I'm currently running a surch for understanding that "option" but i don't find lots of thing...

 Dosen't matter anymore, i'll always rendered it at 512 next time :). If i knew that before, oh my god, so many rendering time i'll save. At least, it will be good for the futur :)

Thank again and again. I was starting to think to abording my project, i only have 17 day left :slight_smile:

:smiley:

Explanation of octree resolution:
https://blenderartists.org/forum/viewtopic.php?t=35427
http://www.blender3d.org/cms/Render_engine_features.215.0.html

Use a high octree resolution for big scenes and a low resolution for small scenes. If you would use a high resolution for small scenes, rendering would take even longer.

Also if the ground/other big flat mesh doesn’t need any fancy raytracing, turn off the option Traceable for that mesh in the material settings.

And I was not aware that you are using ray-tracing!

An “octree” is a divide-and-conquer strategy and the tradeoff is, as always, “speed vs. space.” Since space is very cheap, large trees are usually fine. (If you don’t have enough real-RAM and start swapping, tho, they’ll kill 'ya.)

Nonetheless… particularly for animation I still advocate learning the Sequence Editor. Browse here for previous posts, by me and others. Yes, you have to work at it. Setup is a significant task (although much of it should be automate-able). But you still need to plan to do it. “One minute” for 1/30 of a second of finished material, with the prospect of having to re-do all of it with every change, is still prohibitive.

So there’s no real penalty when using a high octree res in a big scene or a low octree in a little scene?

looks up “penalty” in the dictionary You mean if there’s a downside to it? Nope, it’s a way of tweaking the renderer for your scene. Just tweak properly :wink: