Resetting the existing animation


I have created Human and lip-sync animation and exported the file as POD to execute it on iOS cocos3d app, it worked very well. Then, i included a teeth separately and joined it with human mouth area, by using Ctrl + J key. I tried this updated POD in my iOS app, i could see lip-sync animation along-with teeth included in the human.
Now, i want to separate this teeth alone from the human body, so i did separation using “P” key in editmode for the selection of teeth. Now, the teeth got separated from human body fine in the model.

The issue now is, when i want to execute the model now, its NOT doing even lip-sync , which worked earlier fine. Why is this issue happening after teeth separated? Do i need animate again lip-sync in the dopesheet after teeth separated? I have lots of animation already placed, so i can’t do the animation again, its huge. Is there any way that i can solve this issue in short time (or) Anything like Resetting the existing animation again is possible?

Please advise!