[Resolved] Ceramic with Sub Surface Scatering (SSS)

I saw on Blender website that is possible to reproduce really realistic ceramic and marble effects using SSS.

The Tea Pot example image viewable in SSS page of Release Logs of Blender 2.44 is basically the result I would like to achieve.

So I started some test with a simple model of mine. The model is a cup made with curves.

To begin, I tried to apply one of the template settings, available in the little popup menu of the SSS panel: marble. This is the result.
http://img527.imageshack.us/img527/4816/mortaio3dviewandinfogs1.png
By uklennugtag at 2008-10-13

In the image there are all the Object informations, so you can see the dimensions. I think they are usefull for the Scale value of SSS panel.

This is the screenshot of my Material Buttons view.
http://img527.imageshack.us/img527/138/mortaiomaterialbuttonsrm9.png
By uklennugtag at 2008-10-13

I also placed a Back Light source to see better the SSS effect, but, as you can see my cup, renders black.

If I disable the SSS in SSS panel, of course, the cup correctly renders with its material color.

I resolved. I applied the command Edit -> Segments -> Switch Direction (W, 2 in Edit Mode) to the Cup curves. I guess that the previous direction caused normals to be oriented toward inner side of Cup shape.

I am back to this problem because, even le i resolved previous problem I am not able di obtain al effect like the one linked in the first post.

Any suggestions?

If you can upload the .blend, I’ll check it out and see if I can help.

Thanks, let me find the *.blend file and I will post it here asap.

P.S. Sorry for the spelling errors in the previous message, but I was writing it with an iPod Touch that has a really bad automatic word correction software (it assumes that I am writing in Italian and there is no way to disable it).

Here it is.

It is the best result I have been able to achieve… it is not so bad, but the cup surface loose a lot of diffuse light because of the scatering effect. I would like it to be more “white” and of course it should keep the “wet” effect that real ceramic has.

http://img525.imageshack.us/img525/2799/mortaio01render01co9.jpg
By uklennugtag at 2008-10-28

Attachments

mortaio01.blend (216 KB)

Check the render and .blend to see if this is close to what you’re going for … take a look at the material settings and lighting setup, and tweak as desired. I tried setting it up first in your file, but it seemed to have some render artifacts … so I can’t guarantee that it’ll look the same on your model. Anyway, I hope it helps.

Attachments

SSSmaterial.blend (351 KB)

Thanks. Watching the render you posted here, it seems that the material behave perfectly applied on the monkey.

I will investigate your file. Thanks a lot.

The diffuse light of the SSS surface seems to absorb a lot of light. So I managed to get a better result with my scene setup and your SSS setting, using a low energy Hemi, a key Spot light and using Ambient Occlusion for rendering.

This way, the amount of light in the scene is a lot more, then the simple Ray Tracing. Thanks a lot for your help.

http://img293.imageshack.us/img293/5525/mortaio01render02zr5.jpg
By uklennugtag at 2008-10-28