[Resolved] Images not loading due to SSL Certificate Errors

Hi,

The SSL certificate of our CDN domain has expired, which will cause many image to not load correctly. I have contacted their support team and expect this will be resolved quickly.

Update: this SSL certificate is not managed by us, but by the company that hosts our Content Delivery Network. They experienced additional technical issues today that delayed the installation of a new cert. It has been renewed now, but it may take a few hours to propagate to all users.

5 Likes

expired ?
does this mean blenderartists suddenly became a warez forum ??? :rofl:

Thanks @bartv for the info :slight_smile:

Happy blending !

Quick, download the best software in the world for free before it get legal again!

3 Likes

As a web developer, unintentionally letting an SSL certificate expire is probably one of my biggest fears.

oh noe Autodesk is hiring haxors again
/s

1 Like

They never prevail !!! >8-o

This morning I uploaded an image to help answer a question, and I couldn’t get it to load. Apparently, neither could OP of the thread. However, since that I haven’t been able to load this site at all (until now). It loads a bunch of images, but shows up completely blank. Tried with multiple browsers and devices. Was this also due to the certificate issue?

And, if there are planned or unscheduled downtime, are there any other sites that could provide that info? Sites that shows if a site is down didn’t report any problems, and that the issue was at my end - and I couldn’t figure out what it was - everything else worked just fine.

Thanks for the heads up!

I was about to post a workaround to access the site while the new cert didn’t kick in, but it looks it was solved right now. :slight_smile:

Isn’t the march of technology great.

Features and other things breaking at random and security hoops that are increasingly complicated and expensive to jump through (even if the only thing you use is FOSS). That is not to mention platforms and devices that you have almost no real control over (if it wants to update to a revision with known bugs, sucks to be you).

This type of stuff is one reason why more and more people are becoming a bit “luddite” in their thinking and thereby rejecting the futuristic ideas of tomorrow.

This issue has been resolved by our CDN partner.

2 Likes

You sure? Everything looks crazy on Safari on Mac.

Looks fine for me on Safari/Mac. Perhaps you need to reload or clear some caches?

1 Like

:+1: For me, Chrome / Windows it’s perfect.

1 Like

Everything is okay. :+1:

1 Like