Respower: 'Linking' support ?


I’m doing some tests on respower, I’m having some issues with .blend files wish has “link” objects. Ex: A scene wish loads diferent objects to it, from diferent blend files, and the armatures of the objects have been proxy.

Is there sugestions or work arounds on this? How could I test the integraty of my .blend files, that are rendable in any place out of my lan ? Command line on diferent computer ?
Debugging this issue, on the remote renderfarm takes time, thats why I’m trying to figure that out.

I know Green Button renderfarm doesnt supports this. But I’m not sure, if its me, or respower, that doesnt supports this. I know about the cache etc, actually did tryed it, but it didnt worked also. My last test, has been done with a fisheye lens, its basicly a cam pointing to a hemi (full reflection);

I’ve been doing huge tests, I get a good render output on my LAN, but not when sending to respower. Using 2.48a, and testes 2.47;

Tryed increasing the min ram and processor, without any success!

Is there a way, to keep the way my files are being displayed on the scene, while being “Linked”, and then make them “Append” or something similar ?! The proxy didnt worked, so…

thanks for your time!

Any sugestions is appreciated!

*** I’ve noticed this may have something to do, with the paths I’ve set, they’ve got a help file explaining that we can put everything inside a directory, that goes allong with our render job. I’ll update later

No success at all :stuck_out_tongue:

here’s one of the test files I’ve set
you can open the “cenario” directory wish means “scene”, the output is basicly
blue on respower, wish is the background color for the world.

If you render in your computer you’ll get the red cube plus the blue world.

Maybe respower doesnt support linking?

Respower does support linking… sort of. We used it last year for a project of ours. The thing is that they don’t support relative linking. What they do is have you use absolute linking and mimic their filesystem structure. You have to create a “Y: drive” on your machine and have all of your linked files work relative to that path. Of course, this means that you’re a little bit screwed if you’re working in a non-Windows environment… but at least some form of linking is available.

They actually have more about this (though it could probably be written more clearly) on their site on a page titled Mimic ResPower File System.

Fweeb, Hi!

First of all, let me tell you that I’ve been waiting all this long for an answer, had my project stopped etc, kind of because I needed that information, in case I had to re-think my project. Thanks a lot for answering me back, and even providing me the information needed to set up to render at respower!
Thanks a lot!

Fortunately, I’m on a windows machine, I’m going create that partition ;D

Thanks once again ;D

One important tip for future readers, that was kind a hard to find how to do it.
this one was sugested by mfoxdogg

I already had started the project, so I needed to change the path for all linked objects
to do that, you need to go to outliner and use the dropbox and choose Libraries!
You’ll get all paths displayed, just text based, and to change you need to use the
hotkey “ctrl + lmb”

*For Win 2k\xp\Vista

You can use “Visual Subst”, free program, to make a virtual path,
from a existing directory, like it was a real partition!

thats it :slight_smile:

Unfortunately, there’s no way I had it working :stuck_out_tongue:
I wasted a lot of time, trying and trying without any success at all.

I’ve still didnt got any answer for respower yet, its weekend, I dont know,
but maybe they’ll reply back monday. I callend the support phone line, but
they asked me to contact their support email, wish I had already done.

I’ll update later,


For new files, I can link and user respower to render, just fine.

I have to redone everything on the project. Changing the directories for the libraries,
didnt worked. They do work on your computer, but wont on respower.

So, its better to re-done everything.

Be sure allways to test, all your ideas, before starting something, not to happens
things like mine :stuck_out_tongue:

This is very true, and especially when working with third-party suppliers. Because they can’t be expected to be able to handle all possible configurations of all projects, it’s always best to test first and find a common ground that will return the results you need.

I found ResPower very accommodating in that regard, as long as the questions were addressed before trying to get usable output.


I already got an answer back from them. Before reading it, I had test some other files, with the technique they provide with the virtual disc, that works just fine! Unfortunately, I dont know why, but changing librarie paths on old files, and alocate all files on this new directorie (respower mimic), wont work! There’re many factors that may be contributing to this!

Anyway, they provide a diferent technique! They provide us with Super/Cache, wish can work better :slight_smile:

I’m going test that out, and I’ll give me final toughts about this. I believe its going to be important for future readers and Blender ResPower users =D