retina refraction

Hi, I’m trying to make a clear retina, but it seems it distorts a little too much.
In the first picture there is a ztransp retina and in the second there isn’t a retina piece at all.
Notice the high level of refraction, from a pretty straight on camera view (in the first picture):D.
This is blender internal renderer also, so I’m surprised there’s refraction at all LOL!
I would have been happy with pure transparency and a little reflection.
I like a little bit of refraction though, but is there a way to reign in the refraction,
to cut back on the droopy ‘fish eyed’ look?
Thanks for any advise!

Nevermind, I adjusted the shadowbuffer :smiley:

the clear lens of your eye is called the cornea :wink:

are you sure it is set to Ztrans or Ray Trans

I’m guessing the problem comes from your mesh being modeled incorrectly for real-world refraction. See if the attached diagram helps.


Hey I’m not a doctor :smiley:
Yeah it’s set to ztransp.
Here’s the ‘no shadow buffer’ retinal clear skin flap version;),
which I like better, but it’s completely transparent, except for the light reflection…
You’re right cire, it’s just a single sided retinal flap that I modeled, like a contact lens…
Is there a way to mess with the refraction in Blender Internal render?

To adjust (or, even have) refraction, you need to use RayTrans. The IOR is the main setting you want. But it won’t look right unless you give the structure some thickness.

I should have said “is it possible without raytracing”
That first one is Blender Internal without raytracing enabled, and it seems to refract.
It’s just an illusion though, I just rendered out from different angles, and definitely no refraction.
I see now its just the shadow buffer casting a weird shadow.
I’m making a lot of ‘no raytracing’ experiments, like environmental mapping for reflections,
as I have three very elderly computers…my good one has a fried motherboard,
and raytracing slows things down a lot.
The quality really suffers though, and I can’t wait to fix my good computer.
I thought I found a secret no raytracing refractions thing in BI here. :smiley:

you can turn off ray tracing until you are ready to do the final render
that way you save render times when still modeling other parts or animating etc

just get it looking like you want - then turn it off until you’re ready to render your final image (or animation)