Retopo in 2.5

Has anyone figured out retopo in 2.5? When I use the space bar search it says its under grease pencil, but I do not see it there and I don’t really want to use it in conjunction with grease pencil or anything like that. Is this a feature that has not yet been migrated into 2.5?

PS - Mighty admins, would you consider making an independent forum for 2.5 migration issues? It seems like they could use their own space.

Hi,

there are two ways to do retopo, there is using mesh editing tools with the improved snapping tools. And there is the retopo paint with grease pencil.

For snapping tools - enable the magnet in the 3D header, then set the snapping type to face (ctrl shift tab), then create a new mesh, delete everything and extrude your new mesh and when the new verts are transformed it will snap to the surface.

For grease pencil, you need to add a grease pencil layer, turn on surface snapping, paint your grease pencil strokes (hold down D, then draw a stroke), then use the Space bar search and type retopo to covert the strokes to mesh.

LetterRip

Thanks LetterRip that was just what I needed

Hi LetterRip - I have a question. Do you know if more work will be done on the retopo functionality?

Neither of these options work nearly as well for me as my previous work flow from 2.49 of creating a series of vertices and then projecting them onto another object based on my viewing angle.

You could try adding a Shrinkwrap modifier.

That might work in some situations - but most of the time it wouldn’t work very similar to the way I was using the 2.49 retopo… since it doesn’t really project the vertices onto the object behind it…

LetterRip missed 1 step in his explanation for the Snap tool approach. When in edit mode (and Snap to Face enabled) there is a button next to the ‘Snap Target’ function (Closest being the default). This button has an icon with a sphere and a face with 4 vertex. Enable this button

One more thing. In my experience with 2.5, it’s not enough to Control-click the new vertices for them to snap automatically to the closest face. They seem to be created at the default viewing plane. Maybe I’m doing something wrong. Anyway, what I do afterwards is do a quick fake grab (press G and hit Return). That is enough to snap things into place.

Snapping has changed in 2.5. You can enable snapping (by pressing Shift-tab or pressing the magnet), so you won’t have to press Ctrl all the time. Without snapping enabled Ctrl can still be used for faster access.

anyone can tell me how Face snap and Volume snap work, I tried an example with a 32x32 Grid and a monkey, move the grid close to the monkey with Face Snapping enabled but nothing happened (the grid’s still flat and not seem to snap or retopo to the monkey)
(of course I pressed Ctrl to activate the snap mode)
http://img191.imageshack.us/img191/702/snapping.jpg

U should press that button next to the magnet before you move the grid (the one with the sphere and 4 vertex-plane). Also, the snapping will depend on the view (if there’s nothing behind the grid then there’s nothing to snap to)

cannot work with this retopo!

can somone make a small video like 10 minutes showing the steps to do work with the different new tools for this new retopo in 2.5

i cannot make it work at all!

i 'm with the 25733 so i guess it should work with this version!

Thanks

Thank you Sago, I forgot about the view, put the grid on top of the monkey and under my view, then it works just like retopo
Press G, then Ctrl and those vertices snap on the monkey face :smiley:
http://img63.imageshack.us/img63/9075/snapo.jpg

can you explain the step to retopo the plane onto the suzanne faces?

also i tried with adding vertex and they are added to the middle of suzanne instead of the surface faces of suzanne

anybody can help witht this

Thanks

Thanks Sago. That definitely helped.

Unfortunately from the point of view of doing retopo on a sculpted mesh the tools just aren’t suitable at the point they are at now. I’m sure by the time 2.6 is out they will be better but right now 2.49 is definitely superior in that respect. I was amazed how easy it was to retopo with 2.49 - it felt really intuitive. I’m hoping something similar to that will make it’s way in…

your viewpoint, the monkey and the grid should be arranged like this (if your view is not perpendicular to the grid, the vertices will snap strangely)
http://img695.imageshack.us/img695/451/57846233.jpg
then press G (grab), Ctrl (enable snap)
http://img63.imageshack.us/img63/9075/snapo.jpg
and the result is… (after pull the grid off the monkey face :D)
http://img695.imageshack.us/img695/6189/20420763.jpg

which vesion are you using ?
i got 25733 and don’t thin it’s working
or i;m doing a mistake here a missing step may be !

see pic

i got this
when i do G i can move the grid but Ctrl does not do anything ?

anything wrong with the bottom header?

Thanks

Select the button to the left of the camera icon (3rd button from the right)

Richard

ok working

when i put the cursor over this button i get " broken doc " tip ?

what does it this means ?

would be easier witht a small video 2 or 3 minutes to show the 2 ways of doing this !

Thanks

Word up… I totally agree that current Retopo stuff is not as intuitive. I definetely welcome the new additions and work arounds but the older retopo worked great in many situations.

Also I am not getting any nice results with the grease pencil implementation, not even withuniformly distributed strokes.