Retopo MT

How do I download the script? I cannot find the download button. If there isn’t one are there instructions on how to copy and prepare a text-script for installation into Blender?

press Raw, then right click: Save page as…, add .py for suffix
:wink: now you can put it in “…\scripts\addons….”, enable the addon and enjoy

Thanks burnin. I did not get the “save page as” instead just “save as” was the only option when rt-clicking the raw page. But it worked and was installed! Thank you very much for taking the time to reply.

Hello I tried the Raw Python source code here -->…opo_mt_v_1_0_4 in blender 2.78a and im getting an error when tring to run it.

I finally got the latest version showing up in Blender, but the console i got this …\AppData\Roaming\Blender Foundation\Blender\2.78\scripts\addons\ SyntaxWarning: name ‘g_SavLens’ is assigned to before global declaration global g_SavLens
And the code look like this

just letting you know :slight_smile:

Hi, could someone lay out the differences between retopo MT, and the F2 addon? Are there other free addons? Which are the pros/cons of each? I just got back to working on some older sculpts, and was contemplating to do some retopo. Have the free addons caught up with the paid addon from CGcookie?

Does this addon still work correctly? Automerge doesn’t appear to do anything for me

This add-on is really good. Here are some remarks after retopologizing a model with it :

  • The Brush Cut Size shortcut (Shift+F) has a strange behavior : it reacts to mouse speed. If you move your mouse slowly in either direction, the circle shrinks, which makes it hard to tweak. However, the Brush Size shortcut (F) doesn’t have this problem.
  • The “Enter” shortcut to confirm and exit Retopo MT doesn’t work on my end, only the right-click does. Also It would be good to have Escape to get out of it.
  • for some reason Retopo MT disables ortho view and I can’t bring it back with “5”
  • Why not have the + and - keys in addition to X and W to add or remove cuts ? I find + and - easier to feel without having to look at the keyboard.
  • Some crashes here and there and some isolated vertices after using it. I still have to identify their cause.

What is shortcut for setting the retopo ? If I press ctrl+shift+alt+x nothing happens. How to select multiple vertices ? If I press shift+RClick it doesn’t select multiple vertices but brings UI up.

hands down the best retopo tools blender currently have, easy and fast to use way better than retopoflow imo.

Adding loopcuts while in retopo mode would be appreciated thought.

I have set it up with speedretopo. I’m in right ortographic view. When I click on retopoMT, Blender switches to right perspective view.

How to make it so it does not switch perspective?

If I good remember RetopoMT work only in perspective view. Tip from Pitiwazou: change default blender view from 35 mm to 85 mm. N -> View tab.

Yes, only perspective view.


Anyone else encountered this error? I’m using Retopo_MT with SpeedRetopo but after this error RetopoMT stopped working for me. It also took my mesh with it D: .

Yeah I cannot make RetopoMT work at all in Blender 2.78 with SpeedRetopo. I can enter retopoMT “mode” but I cannot acess any tools or anything while I’m using it.

Nice thanks. I was looking for a good topology addon. I think my search ends here. Let me test it.

I get this error message when trying to install retopo mt (nightly build from Blender builder site):

Haven’t tested it on 2.79.

Does it work in official release?

Thread: Addons Breakages 2.79 master (Nightly Builds)

will try when I come home from work.

So tirinng all the breaking addons for 2.79, going to study some python scripting this weekend so maybe I can fix these things myself :slight_smile: