Rigging problem corroding my own brain

Soo, ive been working on the same project over the last year (i’m not kidding, i’m trying to make a model work for almost a year now), yes, i suffered a crap ton during that time, specially in the 10 retopo attempts i had before being able to advance, but now i’m stuck again, this time on rigging. I finished the final retopo attempt a week ago, and i begun working on it and trying to make it work. For the armatures i just imported a human sample from rigify , adapted it to an anthropomorphic body and added some toes and a tail following a tutorial from youtube. It worked soo far until time to apply the stuff came. At first the rigging came inclined by 45-60 degrees on the X axis , 15 degrees on the Z axis and 5 on the Y axis. This is weird, it wasnt supposed to happen, i thought, and i tried to put it back into place. then i tried to parent it with the main mesh, and that was the moment stuff went downhill. the rigs are completely cursed, some bones dont even have weights on the model while others have on both sides. Overall, its unworkable, and i’m sitting here wondering, WTF is happening?
Can anyone tell me please? i want to finish this quickly i’m already working on it for more than a year. Here’s some pics of the glitch on the angles https://imgur.com/a/HDHgdJK
Please, i am wasting my own brain on this, i’m literally working on this single project for a year already due to retopo
UPDATE - I guess i discovered why stuff is glitching, one side is getting all the weights that the other should, i have no idea why this is happening.
https://i.imgur.com/LJTfgeCh.jpg one side of the bone is getting the weights