Rigging Problems (Automatic weight never works for me - WHY?)


I’m currently trying to rig a character for animation, and it’s a simple character - not overdone or anything, just cartoon characters (Odie and Garfield) - but when I create a Rig, it always gets screwed up - although I’ve seen hundred of movies where people just add bones and shape them and then it works flawlessly. Since these characters are a bit different from ordinary “bodies” I didn’t use the Rigify rig.

Does anyone have any idea why this is ALWAYS happening? I mean, if I have a bone on a finger, and try to rotate that finger the whole damn body just rotates - which is kind of weird.

Attaching a screenshot of the rig and the model.

I just want to get some idea what I’m always doing wrong. 'Cause this never works for me… It always get greatly deformed beyond recognitzion.

  1. Make sure in the armatue modifier that “bone envelopes” is unchecked.
  2. Make sure there is only one armature modifier
  3. If you have overlapping meshes (like perhaps the toungue - I can’t tell) it gets messed up and you get an error

All I know is that for example, I have a left and a right side of the skeleton (X-mirrored) but when I move the left or right leg the other leg move as well, and if I move something like the head, the top of the head gets all disorted and looks weird… (like the ears).

Is there any way that I can export just the Armature and post it here, for someone to take a look at? I mean - It’s probably a problem with relations, or if I need IK’s or something.

I have only used Armature once or twice before, and from all the videos I’ve looked at it seems as if “Automatic Weights” always work.

It’s a bit frustrating.

Example: I move the left to the the left, the right leg moves more to the left than the right leg does.

Does this has something to do with the mesh and it’s faces? Because “automatic” weight does not seem to be correctly.

The bone “foot.L” with automatic weight gets the Vertex groups that should correspond to “foot.R” - which is completly strange.

Simply said, it looks as if the “Bones” are reversed. The left gets to be the right and the right gets to be the left. In the vertex groups at least… Why does this even happen?

This is the armature:

odie_armature.blend (469 KB)

If someone could please check the relations between the bones and if they’re correct it would be greatly appreciated. Whatever I do, wether weight paint, or whatever it still results in a messed up/disorted deformations.

there is no mesh in the file

I know. I was wondering if there’s anything with the Armature that’s wrong - connections and what not.

odie_arm_mesh.zip (1.13 MB)

Here’s the Mesh and the Armature, had to zip it due to filesize.

There is still no mesh - only an empty and the armature

I think you have the mesh linked from another file – that could be the reason for the problem

No, I have a bigger project that takes alot more than 2mb, so I created a new project and Appended Odie and the Armature.

I’ll try again…

odie.zip (1.44 MB)

Here… Hope this works.

Do you have a model of Odie prior to applying subsurf – I used automatic weight painting and it worked as expected – the weight painting is crappy (its really broad and spread), but works left to right – Usuallly, applying a rig is best to a model prior to subsurf

If not, than I would suggest a mesh deform modifier

I never used subsurf, I only used Smooth.

What Daren is trying to say is that it looks like it had a Subsurf modifier once, which was applied later. This mesh is too high poly for nice looking deformation with an armature. Best is to get rid of a lot of redundant edge loops, or simply start over with the model

Ok. I have actually wondered about that, I’m not so good at Blender yet - but this is one of the things I wondered. Is there anyway to “simplify” the model?

I tried using the Deform mesh, but it gave no visual results - or I have no idea how to use it.

I think it’s still “funny” though that the left side (foot in particular and leg) gets the Vertex group that the right side of the foot/leg should have… doesn’t seem like an error in the armature or the mesh, just that’s is somewhat confused.

Or, I get if I try to use it - “Modifier is disabled, skipping apply”

Here is a set of tutorials using a low poly mesh to deform a high poly mesh