Rigging/weight painting problem?

Hey guys, i’m new to rigging here, i’ve been looking through the blender wiki and asked friends for help, but i can’t work out what’s so wrong with this mesh, rig or both :s

I’ve attached a picture showing what’s wrong. Basically i’ve set up a rig that i think is ok, and parented the mesh to it with automatic weights. I’ve gone in and tried to strengthen the weights, but no luck. I’ve exported and reimported the mesh, tried making a new rig from scratch but no luck :expressionless:

Any advice on things i can do to work out the problem will be greatly appreciated, sorry if there’s not enough info here. I’ll check regularly to answer questions if you need more info, i’ m relatively new to Blender as a whole.

did you remember to link the two using the armature modifer? is that pointing to the correct armature?

Check your Mesh object’s Modifiers. You probably have multiple Armature modifiers applied to the mesh. This happens when you start a rig, decide you don’t like it, delete the rig, and parent the mesh to a new rig. The part where you delete the rig does not automatically remove the original Armature modifier from the mesh.

In addition to what kastoria said, if the second rig you created has different bone names from the first rig - upper_arm_L, upper_arm.L then you might have multiple vertex groups influencing the mesh…


Thanks a bunch guys, i did try to make a second rig, but wasn’t sure if i deleted all data related to the old rig, wasn’t sure how tbh :expressionless: I’ll give this all a look over and see if i can get this working.

Thanks again!