Rigging with Riggify problems

i hoped it would work easy to add that human rigify amature to my sculptris model.

but after strg p and amature deform with automatic weights, the body still wont move :frowning:

also i noticed this controle shapes after hitting the generate button, apear in a much to small size compared to the size of my model and the upscaled amature.
i tried to follow this tutorial, but i endet up with just some green rigs enough for a spine, missing all the others like arms, and legs.
also cannot move them.
what the hell is wrong?
i there any idea what i have missed?

what the hell is wrong?
The thing that is wrong is your failure to supply any demo blend file for other users to review so we know as much as you do.

For support questions please at least make some effort to supply all the necessary info to help enable other people to help you

finally i saw the little error info…
error messages in blender are quite hidden -.-

“bone heat weighting: failed to find solutions for one or more bones”
need to fix up my model but its not working.
because oing weightpaint manually is a mess right now…
so i would be happy to find a way to fix my moddel.

I deleted all doubles but couldn’t find the option to recalculate the normals.
I deleted all modifiers too, but it still have the same error.
Since i created the character in scupltris, with mirroring always aplied, it should be symetrical.

I added some extra spheres as eyes in sculptris. could this lead to the error?
or is there a max number of possible scales?

i need something like a checklist to clean up my character

Select the mesh, press tab to go to edit mode, now look at the feet of your character. Is there like a square/plane?
Delete it. I had a problem were I joined the “floor” to my “character mesh”.

I figured it out by process of elimination.
First I deleted everything except one hand and tried to auto/weight it.
That worked fine so it couldint be the arms,
Then I tried deleting only stomach and lower,
auto/weighted fine.

So I knew the problem was near the legs, then I realized that the floor was there,
got rid of it and it auto/weights just fine now.

I was already gifing up, but now it somehow worked.
it seems i finaly found out how to set that normals right (or howewr it was called in that tutorial to wourk that problem out)
i used the wrong shortkey command. but now that [ctr] [shift] [n] worked in the end.
no i will see if i can use that now for better posing :<

its possible to add clothes on the rigged mesh…right?
need to learn how to create them in blender now :stuck_out_tongue: