Right size on the Gravel

Hello I try to add gravel image in to my seafloor and thats without no problem, but I dont get right size on the gravel.
I play with Crop Minimum and Crop Maximum but still not satesfied.
I doing something wrong but can not figger out where. I want the seabed looks like this http://i1023.photobucket.com/albums/af353/Spender19/Gravel0099_3_S.jpg

Can you advice me where to adjust the texture.


uv unwrapping it. then scaling the layout to your liking.

JO5EF thanks for helping. Yes I have try with everything UV- Unwrapping and not. Look at my blendfile and give me some advice.


But it would be better if the texture is seamless.

Craosos . I really appreciate your help but I do not understand what you mean.

Here is graveltexture with the right size , but as soon as I make it bigger it becomes even more/bigger gravel , even in UV unwraps ( A)

You say " It would be better if the texture is seamless. OK . I am totaly lost . I am sure I have not make any duplicate as Cogs Water Surface tutorials (Blender 2.43) there seams need to be conected to be seamless .
Can you show me where I fix this. I try to press this button (E) nothing happen.

In all tutorials that I followed shows them always that after Unvraping choose UV ( B ) but in your picture , you have chosen Generated ? ( C )

I did the same as you, but it did not improve.

When I try to fill this box with this material / texture ( D ) sand become big as stones?

[ http://i1023.photobucket.com/albums/af353/Spender19/Skrmavbild2011-07-14kl093755.jpg ]


in the uv editor, if you scale your layout (not the picture) to a bigger size, the texture will display smaller.
if your layout is larger than your image, you have to set your texture to repeat (in the image mapping tab) in order to cover the whole ground.
then you get to the problem kraosos mentions and is visible in his screenshot: you can see very clearly where your image repeats.(he chose not to use uv unwrapping but generated mapping, which is possible in your case, too)
to solve this you have to make your texture seamless.
there are a couple of ways you can do that, even gimp-plugins which will do the job for you. maybe start here

What JO5EF said - I mean seamless texture (sometimes tileable texture) not seams on mesh. You also have to check Repeat in image mapping menu not Clip:
But it can be better to use particle system for it:

Simply create group of stones and particle system that use the group - than you can create some nice material for the stones and you have it. Here is my really simple setup pasteall.org/blend/7598 (wow limited number of urls - never seen:()


Thank guys for helping. This would help me through the problem.

this is not a blender-problem

attached the same texture but run through gimp.

open in gimp,
select make seemless (nahtlos in german, thats why i used
this name-extent). this option is in the filter-submenu, there
in the mapping-menu (thats where other things are like creating
bump-maps, distortions and so on).

this is the already changed image (one may try more changes …
maybe create a bump-map for it and so on)

and last, to get more light variations, one may not map it
to a flat plane, use a subdivided plane with slight variations (sculpting?).
But this is only necessary for more details. (Last step is to create a all
pebbles with different sizes and color - like already said above)


test-dr, thanks for your advice. I have been working on Gimp plenty of times, but never need to use them in to Blender textures. I have always use images from CG textures http://www.cgtextures.com/

I vill try with Gimp.png. I dont think Blender like Gimp.gif.


Thanks for helping all of you.
I open up a images at Gimp and in filter + mapping + bump map and save as: gravel.jpg
This is the result. http://www.pasteall.org/blend/7600