Rigid bodies react even when they are not touched

The TDLR is I have rigid body simulations that are behaving like they have been in a collision when they have not and I don’t know how to fix it.

I have a assignment for school which involves using keyframes to interact with text. My chosen route was to create a model of the word sniper and keframe a bullet moving through it. Should be simple right?
Create text
Solidify text
Turn text to mesh
Cell fracture mesh
Apply rigid body
Set start deactivated
Set collision to mesh
Copy from active to the rest of the cells
Calculate mass
Put bullet model in scene
Apply keyframes
Apply animated rigid bodies to the bullet

And this works as intended, other then a few cells which I seem to of missed when copying the rigid body.
I selected all the cells again, and copied from active, then recalculated mass. All the things now have physics, but the problem is all the letters “explode” at the same time, even though the S is the only set of cells that have had any interactions.

File is attached below
If anyone has any suggestions, I would greatly appreciate it. Thank you for your time in advance.

Sniper.blend (2.7 MB)

You apply scale to the bullet (although it is recommended that all the objects involved in the simulation have the correct scale applied). Note that you have keyframes in bullet scale, so you will need to replace each keyframe with 1 scale (Use N panel > Transforms to see it). Now with the scale applied, you choose the final size of how you want the bullet to look by scaling in Edit mode (not in object mode)


Also you reduce Sensitivity > Margin to for example 0.005m in bullet and individual fragments (in fragments you can modify the value first in only one of them, select all but the first one as active, right click on the setting you want to copy, and Copy To Selected)

You probably want to enable gravity acceleration when the bullet is reaching the end of the word.

Thank you very much for your suggestions, I should of done them myself but I had it working briefly so I never bothered, but unfortunately the issue is largely the same. The first frame of the collision looks good now, but then everything starts to fall apart (literally).Sniper.blend (3.0 MB)

As I mentioned before, the problem seems to be the acceleration of gravity now. Since the simulation begins, fragments begin to fall due to gravity. There is probably more than one way to deal with that problem. For example you can keyframe “Gravity” there in Scene tab, 0 for 80% of the bullet’s travel, -9.8 when the bullet reaches the end of the word fragments (You can Keyframe the values or just the Gravity checkbox).

Sorry, missed that. I disabled gravity outright and that still results in wonkiness, though admittedly less so. The problems seem to be beginning in the bottom of the letters for some reason, specifically on the right hand side for most of them.

You try Convex Hull type in Shape for all fragments

No clue why, but switching over to convex hull fixed the issue when gravity is disabled. Unfortunately its still broken when gravity is enabled, even if I set it to -.1

Edit: NVM, for some reason sensitivity was disabled. Still not perfect, but at least now its only affecting one letter in front of the actual projectile. Thank you for your help so far.