Rigid body not acting properly

(5_on_it) #1

I have my active objects (Bolts) fall onto a floor object. When they do, either they float above the floor mesh or start going through it. I’ve tried setting the ground to both ‘box’ and ‘mesh’ and neither seem to work right. Just a simple setting I’m missing?

Bolts02

0 Likes

(Gavin Scott) #2

In your Rigid Body properties for the bolt objects, what do you have the Collisions->Shape set to? Have you tried Mesh instead of the default Convex Hull there?

0 Likes

(5_on_it) #3

Yes, I have both set to mesh.

0 Likes

#4

Hi Gavin,

On the rigid bodies ( both dynamic and passive) have you set the sensitivity to a low enough value?

.

You can make this small, like 0.1 mm, but zero will cause things to get erratic.

Dj

0 Likes

(5_on_it) #5

I believe I’ve tried that already, to no avail.

I have also tried replacing the ‘bolts’ with just plain cubes and the floor mesh with a standard plane. With the same results.

This is starting to look like a bug in the Physics Engine. Or perhaps an expected limitation?

0 Likes

(Emir Sinan Gürlek) #6

Could you share the problematic .blend file? I’ve experienced a similar issue when making this project (Olives didn’t touch bowl properly). I couldn’t resolve it but I would like to compare setups and come to conclusion maybe.

0 Likes

(5_on_it) #7

Perhaps later. I’m at work and the file is at home.

0 Likes

(5_on_it) #8

It must have been a bug. I just downloaded the latest 2.8 build (April 15th build) and it seems to be doing a much better job.

1 Like

(5_on_it) #9

Well… maybe mostly fixed? Still strangeness when I switch back to the bolts.Uploading: Screen Shot 2019-04-15 at 3.35.46 PM.png…

0 Likes